Bug 218996 - virt-manager needs to create non-sparse files
virt-manager needs to create non-sparse files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
: FutureFeature
Depends On: 217764
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 18:04 EST by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RC
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 20:35:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Daniel Berrange 2006-12-08 18:12:44 EST
I don't think its practical to make it the default behaviour, because we've not
got the infrastructure neccessary to give the user feedback while creating the
file - creating non-sparse files can take a very long time.   

So, either we need to create a general virt-manager preference to allow
non-sparse files to be turned on, or perhaps more usefully, in the new VM
wizard, add a checkbox option to request a non-sparse VM. The latter is similar
to what VMWare provides when creating a guest.
Comment 3 RHEL Product and Program Management 2006-12-08 18:30:33 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Hugh Brock 2006-12-18 16:07:48 EST
Fixed at virt-manager-0_2_6-5_el5. We create non-sparse files by default with a
checkbox as described above. Also updated the progress dialog to display a
verbose warning when creating a vm with a non-sparse file.
Comment 8 RHEL Product and Program Management 2007-02-07 20:35:36 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.