Bug 21900 - wu-ftpd crash sometimes
wu-ftpd crash sometimes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Dale Lovelace
:
: 14419 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 13:39 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-16 07:09:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace of PID 29417 : this process dies after a transfert (server) (10.63 KB, application/octet-stream)
2000-12-12 12:27 EST, Need Real Name
no flags Details
Yet another strace (pid 29485) (10.79 KB, application/octet-stream)
2000-12-12 12:28 EST, Need Real Name
no flags Details
Yet another strace (pid 29558) (10.45 KB, application/octet-stream)
2000-12-12 12:28 EST, Need Real Name
no flags Details
Yet another strace (29577) (10.95 KB, application/octet-stream)
2000-12-12 12:29 EST, Need Real Name
no flags Details
Don't close already closed FILE* (1.83 KB, patch)
2001-03-12 12:19 EST, WU-FTPD Development Group
no flags Details | Diff

  None (edit)
Description Need Real Name 2000-12-07 13:39:48 EST
Hello.

I run a busy ftp server (about 35 000 xferlog lines a day). Since
I've upgraded the system to RH7.0, I have, in /var/log/messages, lines
like:

Dec  7 19:24:26 colt1 ftp[29557]: exiting on signal 11: Segmentation fault

I ran 'strace -fp <pid_of_inetd>' and traced faulty ftpd. I now have
4 log files (one per pid) showing wu-ftpd performing a SIGSEGV at the
end of a transfert, just after producing message #426 ("426 Data
connection: ..").

The system has been updated with the latest patch and is managed by
RedHatNetwork (colt1.cpio.com).

I can give the 4 log files to RH tech staff upon request (about 10K after
gzip, 150K before). Full log file of all process launched by inetd
can be given also (55 megs before gzip, 4.3megs after :-))

Thanks.
Comment 1 Bernhard Rosenkraenzer 2000-12-12 11:52:53 EST
Please add the log files - I can't reproduce the problem here (and looking at
the code doesn't show something obviously wrong).
Comment 2 Need Real Name 2000-12-12 12:27:05 EST
Created attachment 6293 [details]
Trace of PID 29417 : this process dies after a transfert (server)
Comment 3 Need Real Name 2000-12-12 12:28:06 EST
Created attachment 6294 [details]
Yet another strace (pid 29485)
Comment 4 Need Real Name 2000-12-12 12:28:46 EST
Created attachment 6295 [details]
Yet another strace (pid 29558)
Comment 5 Need Real Name 2000-12-12 12:29:48 EST
Created attachment 6296 [details]
Yet another strace (29577)
Comment 6 Need Real Name 2000-12-12 12:31:46 EST
So you get the strace of the 4 pids that crashed as I wrote. I can
also send the full strace of inetd, but I do not want to post it
in a public place like here since it may give information about
the computer it was taken from. I can send it to a particular person
however.

Thanks.
Comment 7 WU-FTPD Development Group 2000-12-21 10:13:46 EST
I knew there was a bug like this and that it had to do with dropped 
connections.  This information has helped me localize the problem.

Give me a few days to work up a patch.
Comment 8 Need Real Name 2001-02-08 11:34:54 EST
I am having exactly the same problem:
Feb  6 19:17:20 ftp ftpd[1560]: exiting on signal 11: Segmentation fault

The FTP server is running version wu-2.6.1(1) as shipped with RH7.0.
Is the patch mentioned above available yet?  Thanks.
Comment 9 WU-FTPD Development Group 2001-03-12 12:19:52 EST
Created attachment 12404 [details]
Don't close already closed FILE*
Comment 10 Bernhard Rosenkraenzer 2001-03-16 07:08:52 EST
*** Bug 14419 has been marked as a duplicate of this bug. ***
Comment 11 Bernhard Rosenkraenzer 2001-05-15 11:21:55 EDT
This is fixed in Red Hat Linux 7.1

Note You need to log in before you can comment on or make changes to this bug.