Bug 219001 - RHEL5 beta2 kernel bug at list_debug.c [NEEDINFO]
RHEL5 beta2 kernel bug at list_debug.c
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 18:33 EST by quincyw
Modified: 2014-06-02 09:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (quincyw)


Attachments (Terms of Use)

  None (edit)
Description quincyw 2006-12-08 18:33:46 EST
list_add corruption. next->prev should be d
fe92fe8, but was c56adf40
------------[ cut here ]------------
kernel BUG at lib/list_debug.c:26!
invalid opcode: 0000 [#1]
SMP 
last sysfs 
file: /devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:03:0e.0/host
0/target0:1:0/0:1:0:0/vendor
Modules linked in: hfsplus autofs4 hidp rfcomm l2cap bluetooth sunrpc 
ip_conntra
ck_netbios_ns ipt_REJECT iptable_filter ip_tables xt_state ip_conntrack 
nfnetlin
k xt_tcpudp ip6table_filter ip6_tables x_tables ipv6 video sbs i2c_ec button 
bat
tery asus_acpi ac parport_pc lp parport intel_rng sg floppy e1000 e752x_edac 
pcs
pkr edac_mc i2c_i801 i6300esb i2c_core serio_raw ide_cd cdrom dm_snapshot 
dm_zer
o dm_mirror dm_mod stex sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
CPU:    0
EIP:    0060:[<c04e834f>]    Not tainted VLI
EFLAGS: 00010092   (2.6.18-1.2747.el5 #1) 
EIP is at __list_add+0x27/0x62
eax: 00000048   ebx: cd748888   ecx: 00000096   edx: 00000000
esi: dfe92fe8   edi: c56ad27c   ebp: dfe92fe0   esp: c554beb8
ds: 007b   es: 007b   ss: 0068
Process kblockd/0 (pid: 15, ti=c554b000 task=c555e000 task.ti=c554b000)
Stack: c063d900 dfe92fe8 c56adf40 dfe44680 c56ad27c 00000000 c04dac67 00000000 
       00000000 00000000 00000001 00000001 00000001 dfb8bb60 dfe9ec00 dfb49800 
       dfb8bb60 e0872170 dfb8bb60 c04d9428 c0674d70 c56ad27c dfb8bb60 dfb8bb60 
Call Trace:
 [<c04dac67>] blk_queue_start_tag+0xd6/0xe3
 [<e0872170>] scsi_request_fn+0x119/0x313 [scsi_mod]
 [<c04d9451>] __generic_unplug_device+0x1d/0x1f
 [<c04da39f>] generic_unplug_device+0x15/0x22
 [<c04db103>] blk_unplug_work+0x6c/0x74
 [<c0433899>] run_workqueue+0x83/0xc5
 [<c0434171>] worker_thread+0xd9/0x10c
 [<c0436620>] kthread+0xc0/0xec
 [<c0404d63>] kernel_thread_helper+0x7/0x10
DWARF2 unwinder stuck at kernel_thread_helper+0x7/0x10
Leftover inexact backtrace:
 =======================
Code: c4 0c 5b c3 57 89 c7 56 89 d6 53 89 cb 83 ec 0c 8b 41 04 39 d0 74 1c 89 
54
 24 04 89 44 24 08 c7 04 24 00 d9 63 c0 e8 a0 d2 f3 ff <0f> 0b 1a 00 b2 d8 63 
c0
 8b 06 39 d8 74 1c 89 5c 24 04 89 44 24 
EIP: [<c04e834f>] __list_add+0x27/0x62 SS:ESP 0068:c554beb8
Comment 1 Linda Wang 2007-08-20 12:21:42 EDT
has anyone seen this issue with RHEL5 GA bits?
Comment 2 Ernie Petrides 2007-09-05 16:14:30 EDT
Does this problem still exist with the RHEL5.1 beta kernel?
Comment 9 Linda Wang 2008-07-16 14:07:39 EDT
Has this issue been seen again recently?  
Comment 11 Alex Chekholko 2009-05-05 14:46:02 EDT
I am seeing something similar in 2.6.18-128.el5 and 2.6.18-128.1.6.el5.  How do I tell if it's the same issue?


list_add corruption. next->prev should be ffff810107e67ed0, but was 0000014800000000
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at lib/list_debug.c:26
invalid opcode: 0000 [1] SMP 
last sysfs file: /devices/pci0000:00/0000:00:00.0/class
CPU 1 
...


http://bugs.centos.org/view.php?id=3524

http://episteme.arstechnica.com/eve/forums/a/tpc/f/96509133/m/931005058931
Comment 12 bob bownes 2010-03-03 14:48:49 EST
I just got the same error in 5.4

root@usageb02 ~ # release
Red Hat Enterprise Linux Server release 5.4 (Tikanga)
root@usageb02 ~ # uname -a
Linux usageb02 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
root@usageb02 ~ #

lockd_down: lockd failed to exit, clearing pid^M
<157>Feb 28 19:55:06 usageb02 lockd_up: no pid, 2 users??^M
<157>Feb 28 19:55:06 usageb02 list_add corruption. prev->next should be ffff81042fe117d8, but was 0000000000000000^M
<157>Feb 28 19:55:06 usageb02 ----------- [cut here ] --------- [please bite here ] ---------^M
<157>Feb 28 19:55:06 usageb02 Kernel BUG at lib/list_debug.c:31^M
<157>Feb 28 19:55:06 usageb02 invalid opcode: 0000 [1] SMP ^M
<157>Feb 28 19:55:06 usageb02 last sysfs file: /class/fc_remote_ports/rport-1:0-9/scsi_target_id^M
<157>Feb 28 19:55:06 usageb02 CPU 3 ^M
<157>Feb 28 19:55:06 usageb02 Modules linked in: nfs fscache nfs_acl mptctl mptbase ipmi_si(U) ipmi_devintf(U) ipmi_msghandler(U) ipv6 xfrm_nalgo crypto_api autofs4 lockd sunrpc dm_round_robin dm_multipath scsi_dh video hwmon backlight sbs i2c_ec i2c_core button battery asus_acpi acpi_memhotplug ac parport_pc lp parport i5000_edac shpchp edac_mc bnx2 pcspkr sg hpilo serio_raw dm_raid45 dm_message dm_region_hash dm_mem_cache dm_snapshot dm_zero dm_mirror dm_log dm_mod qla2xxx scsi_transport_fc cciss sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd^M
<157>Feb 28 19:55:06 usageb02 Pid: 16907, comm: lockd Tainted: G      2.6.18-164.el5 #1^M
<157>Feb 28 19:55:06 usageb02 RIP: 0010:[<ffffffff80151298>]  [<ffffffff80151298>] __list_add+0x48/0x68^M
<157>Feb 28 19:55:06 usageb02 RSP: 0000:ffff81018f45ded0  EFLAGS: 00010082^M
<157>Feb 28 19:55:06 usageb02 RAX: 0000000000000058 RBX: ffff81042fe117d8 RCX: 0000000000000086^M
<157>Feb 28 19:55:06 usageb02 RDX: 00000000ffffffff RSI: 0000000000000000 RDI: ffffffff80308c5c^M
<157>Feb 28 19:55:06 usageb02 RBP: ffffffff88444900 R08: 00000000000000a0 R09: 000000000000003c^M
<157>Feb 28 19:55:06 usageb02 R10: 0000000000000000 R11: 0000000000000000 R12: ffffffff88444900^M
<157>Feb 28 19:55:06 usageb02 R13: 00000002f3df20ed R14: 0000000000000000 R15: ffff810214a96e80^M
<157>Feb 28 19:55:06 usageb02 FS:  00002b1d187ae6e0(0000) GS:ffff81042ff26640(0000) knlGS:0000000000000000^M
<157>Feb 28 19:55:06 usageb02 CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b^M
<157>Feb 28 19:55:06 usageb02 CR2: 00007ffff470c000 CR3: 000000030659d000 CR4: 00000000000006e0^M
<157>Feb 28 19:55:06 usageb02 Process lockd (pid: 16907, threadinfo ffff81018f45c000, task ffff81042f46c860)^M
<157>Feb 28 19:55:06 usageb02 Stack:  ffffffff88444900 ffff81042fe10000 ffff81042fe10000 ffffffff8001ca64^M
<157>Feb 28 19:55:06 usageb02  ffff81018f45df20 0000000000000286 00000002f3df20ed ffff81041fb8e000^M
<157>Feb 28 19:55:06 usageb02  ffff81003b744140 0000000000000003 ffffffff8842e1cd ffffffff8842e2de^M
<157>Feb 28 19:55:06 usageb02 Call Trace:^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8001ca64>] __mod_timer+0xa3/0xbe^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8842e1cd>] :lockd:lockd+0x0/0x2bf^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8842e2de>] :lockd:lockd+0x111/0x2bf^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8005dfb1>] child_rip+0xa/0x11^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8842e1cd>] :lockd:lockd+0x0/0x2bf^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8842e1cd>] :lockd:lockd+0x0/0x2bf^M
<157>Feb 28 19:55:06 usageb02  [<ffffffff8005dfa7>] child_rip+0x0/0x11^M
<157>Feb 28 19:55:06 usageb02 ^M
<157>Feb 28 19:55:06 usageb02 ^M
<157>Feb 28 19:55:06 usageb02 Code: 0f 0b 68 e9 41 2b 80 c2 1f 00 4c 89 63 08 49 89 1c 24 4c 89 ^M
<157>Feb 28 19:55:06 usageb02 RIP  [<ffffffff80151298>] __list_add+0x48/0x68^M
<157>Feb 28 19:55:06 usageb02  RSP <ffff81018f45ded0>^M
Comment 13 RHEL Product and Program Management 2014-03-07 08:45:54 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 14 RHEL Product and Program Management 2014-06-02 09:20:22 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.