Bug 219021 - Bad HTML rendering
Bad HTML rendering
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 07:53 EST by Marcos Martins da Silva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 11:51:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
original mesage on my inbox (258.74 KB, image/png)
2006-12-09 07:55 EST, Marcos Martins da Silva
no flags Details
message on my sent folder just after I have forward the message (250.22 KB, image/png)
2006-12-09 07:57 EST, Marcos Martins da Silva
no flags Details
message I have forwarded to my wife on her inbox folder (241.71 KB, image/png)
2006-12-09 07:59 EST, Marcos Martins da Silva
no flags Details
source of the original message (38.73 KB, text/plain)
2006-12-09 08:00 EST, Marcos Martins da Silva
no flags Details
source of evolution generated source during forward process (43.81 KB, text/plain)
2006-12-09 08:01 EST, Marcos Martins da Silva
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 393200 None None None Never

  None (edit)
Description Marcos Martins da Silva 2006-12-09 07:53:09 EST
Description of problem:


Version-Release number of selected component (if applicable):
I'm using an up-to-date FC6 (12/09/2007) and evolution-2.8.2.1-2.fc6

How reproducible:
It happens every time I receive a HTML formated e-mail from a newspaper

Steps to Reproduce:
1. I have just to receive a HTML formated message from this newspaper
2.
3.
  
Actual results:
The contents are misplaced so it's difficult to read and it's pretty ugly as you
can see on attached file (cap_1.png)

Expected results:
A correct rendering as you can see on attached files (cap_2.png and cap_3.png)


Additional info:
That's the most weird: I get a bad rendering when I receive the message
(cap_1.png), but when I forward the message I get a well rendered message on my
"sent messages" (you will see "enviadas") selected folder as in cap_2.png and on
 inbox of the person I forward the message as you can see on cap_3.png. I
guessed there was a problem with the original message from my newspaper that was
fixed by evolution during the forward process, but when I see the original
message using  several webmail clients or microsoft outlook I get a correct html
rendering. I'm also attaching the source of the original message (source1.txt)
and the evolution generated source during forward process (source2.txt). They
are too different!! This newspaper subscription is very old and I use evolution
since first time it appeared on Fedora Core. I think this problem has appeared
since evolution was ported to mono. I have waited some releases before reporting
this bug. But I think now it's a good moment to report it.
Comment 1 Marcos Martins da Silva 2006-12-09 07:55:43 EST
Created attachment 143209 [details]
original mesage on my inbox
Comment 2 Marcos Martins da Silva 2006-12-09 07:57:27 EST
Created attachment 143210 [details]
message on my sent folder just after I have forward the message
Comment 3 Marcos Martins da Silva 2006-12-09 07:59:02 EST
Created attachment 143211 [details]
message I have forwarded to my wife on her inbox folder
Comment 4 Marcos Martins da Silva 2006-12-09 08:00:08 EST
Created attachment 143212 [details]
source of the original message
Comment 5 Marcos Martins da Silva 2006-12-09 08:01:18 EST
Created attachment 143213 [details]
source of evolution generated source during forward process
Comment 6 Marcos Martins da Silva 2006-12-09 08:05:39 EST
Sorry, I think I have seen "Back to the Future" more than I should. My FC6 is
updated to 12/09/2006 level not 12/09/2007.
Comment 7 Marcos Martins da Silva 2007-01-04 22:55:23 EST
Hi Matthew, I am pretty aware this bug is not top priority but, as I've reported
it almost a month ago, I was expecting at least some words by now. Thanks.
Comment 8 Matthew Barnes 2007-01-05 11:51:46 EST
Apologies for taking so long to respond.

This sounds like a rendering issue in gtkhtml3.  Unfortunately I don't think I'm
going to be able to address this in a timely manner, so I'm going to move the
bug report upstream to put it in front of a wider audience where it will have a
better chance of getting fixed.  I'll continue to track the problem there. 
Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=393200

Note You need to log in before you can comment on or make changes to this bug.