Bug 219041 - Newest packet missing with real time updates
Newest packet missing with real time updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
http://bugs.wireshark.org/bugzilla/sh...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 15:48 EST by Kasper Dupont
Modified: 2007-12-21 05:07 EST (History)
0 users

See Also:
Fixed In Version: 0.99.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 05:07:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2006-12-09 15:48:05 EST
Description of problem:
When the list of packets is updated in real time, the newest packet does not
show up.

Version-Release number of selected component (if applicable):
wireshark-0.99.4-1.fc5

How reproducible:
Happens every time.

Steps to Reproduce:
1. Start wireshark
2. Click capture options
3. Specify filter "port 53"
4. Chose "Update list of packets in real time"
5. Click start
6. Do a DNS query from another program
7. Do another DNS query
 
Actual results:
The other program reports the result immediately, but wireshark only shows the
query, not the result. When the second query is send wireshark shows the first
response and the second query, but the second respons is sent.

Expected results:
The packet shows up in the wireshark window when it is received.

Additional info:
When I stop the capture, the packet shows up.
Comment 1 Radek Vokal 2006-12-12 03:45:23 EST
Is this bug already reported upstream? 
Comment 2 Kasper Dupont 2006-12-13 01:21:58 EST
I have not reported it upstream. I haven't even verified which versions are
affected. Though I think I would have noticed if the problem existed in ethereal
as well.
Comment 3 Radek Vokal 2007-01-16 07:53:51 EST
Can you please test this bug with the latest rawhide wireshark-0.99.5? I believe
this issue is fixed.
Comment 4 Kasper Dupont 2007-01-23 00:22:27 EST
0.99.4-1.fc5 is the newest wireshark for FC5. And for some reason the problem
has gotten worse since I reported this problem. Now I don't see any incomming
packets at all, only outgoing packets are shown. But it is the same wireshark
version as back then, so there has to be another reason for that change, maybe
the kernel has something to say, I'm currently using 2.6.18-1.2257.fc5 and when
I reported the problem I think I was using kernel-2.6.18-1.2239.fc5.
Comment 5 Radek Vokal 2007-02-01 09:14:57 EST
This bug is known by upstream and according to this thread
http://wireshark.org/lists/wireshark-dev/200609/msg02347.html
not easily solvable.

Comment 6 Kasper Dupont 2007-02-08 16:16:45 EST
I can reproduce the problem with wireshark-0.99.5-1.fc5 as well.
Comment 7 Radek Vokal 2007-12-21 05:07:09 EST
According to upstream bug this is fixed in the newest release. 

Note You need to log in before you can comment on or make changes to this bug.