Bug 219054 - mailman init script usage help is missing the status command
mailman init script usage help is missing the status command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-09 23:25 EST by Todd Zullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-23 08:56:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated init patch that adds status to the usage output (294 bytes, patch)
2006-12-09 23:25 EST, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Todd Zullinger 2006-12-09 23:25:12 EST
Description of problem:
The mailman init script is patched (mailman-init.patch) in Fedora Core and Red
Hat to include a usage output when no command is specified (e.g. "service
mailman" or "/etc/init.d/mailman").  This was brought up in BZ #162724. 
However, this patch does not add the status command which is added by another FC
& RH patch (mailman-2.1-mailmanctl-status.patch).

Version-Release number of selected component (if applicable):
mailman-2.1.9-2 (and earlier)

How reproducible:
Always

Steps to Reproduce:
1. run "service mailman"
2. view usage
3. notice status isn't listed
  
Actual results:
No status command in the usage info

Expected results:
usage info including status command

Additional info:
I only notices this because I'm lazy and I use the bash-completion package which
offers tab completion of init script commands.  When completing the commands for
the mailman init script I saw that status was missing even though I knew it to
be available.

An updated mailman-init.patch is attached (for posterity and completeness sake
more than for the amount of time or effort it may (or may not) save the mailman
package maintainer :).
Comment 1 Todd Zullinger 2006-12-09 23:25:12 EST
Created attachment 143236 [details]
Updated init patch that adds status to the usage output
Comment 2 Florian La Roche 2007-01-23 08:56:34 EST
Added to -4.

Thanks a lot,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.