Bug 219068 - rpmlint does not catch duplicate %changelog entries
rpmlint does not catch duplicate %changelog entries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 05:52 EST by manuel wolfshant
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.79-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 11:06:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description manuel wolfshant 2006-12-10 05:52:31 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create a spec which includes %changelog twice
2.run rpmlint against either the source or the binary rpm

  
Actual results:
none

Expected results:
a warning about the duplicate entry should be issued

Additional info:
The problem was seen here:
https://www.redhat.com/archives/fedora-extras-commits/2006-December/msg00666.html.
One can notice that the spec (last lines at the above URL) introduces a
duplicate for the %changelog entry. This error is not detected by rpmlint:
#rpmlint ssmtp-2.61-11.src.rpm
W: ssmtp unversioned-explicit-provides MTA
W: ssmtp unversioned-explicit-provides smtpdaemon
W: ssmtp unversioned-explicit-provides %{_sbindir}/sendmail
#rpmlint ssmtp-2.61-11.i386.rpm
W: ssmtp unstripped-binary-or-object /usr/sbin/ssmtp
W: ssmtp symlink-should-be-relative /usr/sbin/sendmail.ssmtp /usr/sbin/ssmtp
W: ssmtp symlink-should-be-relative /usr/bin/newaliases.ssmtp /usr/sbin/ssmtp
W: ssmtp symlink-should-be-relative /usr/bin/mailq.ssmtp /usr/sbin/ssmtp
#rpm -q rpmlint
rpmlint-0.78-2.fc6.noarch
Comment 1 Ville Skyttä 2006-12-10 17:40:36 EST
Check added upstream, will be in the next version:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1300
Comment 2 Ville Skyttä 2007-01-03 11:26:22 EST
Reopening until a fixed version is shipped in Fedora.
Comment 3 Ville Skyttä 2007-02-02 11:06:47 EST
Done in upcoming 0.79-1.

Note You need to log in before you can comment on or make changes to this bug.