Bug 219077 - "yum install" and "yumdownloader --source" fail
"yum install" and "yumdownloader --source" fail
Status: CLOSED DUPLICATE of bug 219029
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 10:05 EST by Roozbeh Pournader
Modified: 2014-01-21 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 00:48:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the problem in yum (529 bytes, patch)
2006-12-10 11:49 EST, Roozbeh Pournader
no flags Details | Diff

  None (edit)
Description Roozbeh Pournader 2006-12-10 10:05:27 EST
Description of problem:
yumdownloader --source crashes on rawhide.

Version-Release number of selected component (if applicable):
yum-utils-1.0.1-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. yumdownloader --source gtk2
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in <module>
    main()
  File "/usr/bin/yumdownloader", line 129, in main
    name = newpkg.returnSimple('sourcerpm').rsplit('-',2)[0]
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 66, in
returnSimple
    (self.pkgID,))
AttributeError: YumAvailablePackageSqlite instance has no attribute 'pkgID'
Comment 1 Roozbeh Pournader 2006-12-10 11:49:39 EST
Created attachment 143246 [details]
patch to fix the problem in yum

Ah, this is a yum problem, not a yum-utils one, and also makes "yum install"
stop working. Attaching a patch that fixes both.
Comment 2 Seth Vidal 2006-12-11 00:48:10 EST

*** This bug has been marked as a duplicate of 219029 ***

Note You need to log in before you can comment on or make changes to this bug.