Bug 219101 - PIN entry times out in about 2 seconds
PIN entry times out in about 2 seconds
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: minicom (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaromír Cápík
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 16:37 EST by Matthew Booth
Modified: 2016-01-31 20:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 07:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2006-12-10 16:37:48 EST
Description of problem:
I have configured 2 bluetooth devices (both phones) in
/etc/bluetooth/rfcomm.conf. I am attempting to establish a connection with
minicom. With both phones, when I initiate a connection to /dev/rfcomm{0,1}, the
phone prompts me to accept a connection, which I accept. The phone then prompts
me for a pin. If I don't type anything, the prompt disappears in about 2
seconds. Sometimes, before the prompt has disappeared, a message pops out of the
Bluetooth icon in the notification area. It normally disappears before I can
click on it, but when I do manage to click on it, the pin prompt on the phone
has gone before I have had a chance to enter anything.

This problem was the same on RHEL 4, however you could specify pin_helper in
/etc/blueooth/hcid.conf, eg:
echo PIN:1

You have a chance to enter this single digit pin before the timeout.

My two phones are a Nokia 6021 and a Nokia N70. The N70 is Series 60, whereas
the 6021 is not. These phones are very different, and display identical behaviour.

Version-Release number of selected component (if applicable):
bluez-utils-3.7-2.i386

How reproducible:
Always

Steps to Reproduce:
1. Add a phone's details to rfcomm.conf
2. restart 'bluetooth' service
3. connect to rfcomm device with minicom
  
Actual results:
Impossibly short window of opportunity to enter a pin

Expected results:
A humanly achievable opportunity to enter a pin
Comment 1 David Woodhouse 2006-12-10 17:11:55 EST
I believe the problem here lies with minicom -- it doesn't wait long enough for
the device to open.

Please try cu (from the uucp package), or just '< /dev/rfcomm0', to pair with
the phone. After that, minicom should work -- sometimes. Sometimes the time it
takes even without having to pair is too long for minicom.
Comment 2 Jaromír Cápík 2011-10-20 08:31:44 EDT
Hello Matthew.

I became a new minicom maintainer and just looking at the issue.
Could You please verify if the issue is still present with the latest updates of minicom and bluez-utils? A lot of things around bluetooth have changed during the past years.

Thanks in advance.
Jaromir.
Comment 3 Matthew Booth 2011-10-20 10:01:50 EDT
(In reply to comment #2)
> Hello Matthew.
> 
> I became a new minicom maintainer and just looking at the issue.
> Could You please verify if the issue is still present with the latest updates
> of minicom and bluez-utils? A lot of things around bluetooth have changed
> during the past years.

I haven't looked at this in years, and I no longer have a system available to replicate it. Feel free to close it.
Comment 4 Jaromír Cápík 2011-10-24 07:55:31 EDT
Thanks for the answer. Since we're unable to reproduce the issue, I'm closing this bug. Feel free to re-open if the issue occurs again with the latest updates.

Jaromir.

Note You need to log in before you can comment on or make changes to this bug.