Bug 219102 - virt-inst fails when installing from localhost
virt-inst fails when installing from localhost
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 16:45 EST by Ruben Kerkhof
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 20:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruben Kerkhof 2006-12-10 16:45:11 EST
Description of problem:

I have setup an nfs export with the fedora core 6 installation tree. When I try to install a xen host with
virt-install -n nfstest -r 256 -f /var/xen/nfstest -s 4 -l nfs:localhost:/export/fedora, virt-install 
fetches the kernel and ramdisk from the nfs mount and starts anaconda. Anaconda fails however, with 
"That directory could not be mounted from server".

It took me a while to realize that, since anaconda now runs on the xen-host, it can't mount an nfs 
export from localhost, you have to specify the hostname or the ip of the nfs server.
So virt-install -n nfstest -r 256 -f /var/xen/nfstest -s 4 -l nfs:192.168.1.15:/export/fedora works.
Installing over FTP or HTTP fails for the same reason.

This is not a major issue, but it would be nice if this was specified somewhere in the manpage or on the 
wiki, or maybe give the user an error if localhost or 127.0.0.1 is specified.

Version-Release number of selected component (if applicable):

[root@odin ~]# uname -r
2.6.18-1.2849.fc6xen

[root@odin ~]# rpm -qa | grep virt
libvirt-python-0.1.9-1.fc6
virt-manager-0.2.6-2.fc6
python-virtinst-0.95.0-1.fc6
libvirt-0.1.9-1.fc6

How reproducible:

virt-install -n nfstest -r 256 -f /var/xen/nfstest -s 4 -l nfs:localhost:/export/fedora
Comment 1 Red Hat Bugzilla 2007-07-24 20:03:43 EDT
change QA contact
Comment 2 Daniel Berrange 2007-09-24 20:02:26 EDT
The NFS url 'nfs:localhost:/export/fedora' gets passed through to Anaconda in
the guest OS. Obviously when resolved inside the guest, 'localhost' is now
refering to the guest OS, and not the host OS. You need to use the real public
hostname, or IP address, and not localhost.

Note You need to log in before you can comment on or make changes to this bug.