Bug 219117 - Error while saving song information
Error while saving song information
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
: 218136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-10 23:23 EST by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 08:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2006-12-10 23:23:27 EST
Description of problem:

Recently, tag editing was enabled in the Fedora build of rhythmbox, but each
time I attempt to edit the properties of a song, I get the following dialog:

--------------------------------------
Error while saving song information

Internal GStreamer problem; file a bug

                          [ X Close ]
--------------------------------------

So I'm filing a bug report.


Version-Release number of selected component (if applicable):

rhythmbox-0.9.5-8.fc6


How reproducible:

Each time you try to change a songs metadata.


Steps to Reproduce:
1. Open rhythmbox and select a song (track).
2. Right click the track and select properties.
3. Change a property (in my case I'm trying to capitalize some words).

 
Actual results:

The display updates suggesting the changes have been made, but after ashort time
the dialog appears and the display reflects the failure to make changes.


Expected results:

That the changes would be made successfully.

Additional info:

I'm trying to edit tag information for an OGG file.
Comment 1 John Thacker 2007-01-19 09:07:10 EST
*** Bug 218136 has been marked as a duplicate of this bug. ***
Comment 2 Bastien Nocera 2007-01-30 13:24:37 EST
Could you please check whether the same thing occurs with Rhythmbox 0.9.6 that
was uploaded to the FC6 updates recently?
Or with 0.9.7 in devel?

Which exact version of gstreamer and co. are you using as well?
Comment 3 Rodd Clarkson 2007-01-30 19:19:47 EST
I'm using:

[rodd@localhost Desktop]$ rpm -qa rhythmbox gstreamer\*
gstreamer-ffmpeg-0.10.2-0.3.20061108.lvn6
gstreamer-python-0.10.6-1.fc6
gstreamer-plugins-bad-0.10.4-0.gst.1.6
gstreamer-tools-0.10.11-0.gst.1.6
gstreamer-plugins-ugly-0.10.5-1.lvn6
gstreamer-0.10.11-0.gst.1.6
rhythmbox-0.9.7-1.fc6
gstreamer-plugins-good-0.10.4-1.fc6
gstreamer-plugins-base-0.10.11-0.gst.1.6
[rodd@localhost Desktop]$ 

I tried rhythmbox-0.9.7-6.fc7.i386.rpm but is has issues with dependancies
(which I will try and resolve if you really want, but it's a production box)

[rodd@localhost tmp]$ sudo rpm -Uvh rhythmbox-0.9.7-6.fc7.i386.rpm 
Password:
error: Failed dependencies:
        libpython2.5.so.1.0 is needed by rhythmbox-0.9.7-6.fc7.i386
[rodd@localhost tmp]$ 
Comment 4 Bastien Nocera 2007-01-30 19:26:56 EST
The rawhide version has nothing more than the current one. I'll try and reproduce.
Comment 5 Tony Tsui 2007-01-31 06:32:58 EST
I'm using pretty much the same:

[tony@rifter ~] rpm -qa rhythmbox gstreamer\*
gstreamer-plugins-base-0.10.10-1.fc6.x86_64
gstreamer-devel-0.10.10-2.fc6.x86_64
gstreamer-plugins-ugly-0.10.5-1.lvn6.x86_64
gstreamer-0.10.10-2.fc6.x86_64
gstreamer-devel-0.10.10-2.fc6.i386
gstreamer-plugins-good-0.10.4-1.fc6.x86_64
gstreamer-tools-0.10.10-2.fc6.x86_64
gstreamer-plugins-base-0.10.10-1.fc6.i386
rhythmbox-0.9.7-1.fc6.x86_64
gstreamer-0.10.10-2.fc6.i386
Comment 6 Joel Andres Granados 2007-04-06 10:41:16 EDT
The bug is far more serious than what is described above.  It not only does no
save the information, it changes all the song info that existed before the song
was edited.  "···z" is now the Artist name of most of the songs I changed.  This
olny happend with the songs which information I have change.

gstreamer-0.10.10-2.fc6
gstreamer-tools-0.10.10-2.fc6
gstreamer-plugins-base-0.10.10-1.fc6
rhythmbox-0.9.7-1.fc6
gstreamer-plugins-good-0.10.4-3.fc6
gstreamer-plugins-ugly-0.10.5-1.lvn6
gstreamer-0.10.10-2.fc6
gstreamer-plugins-base-0.10.10-1.fc6
Comment 7 Bastien Nocera 2007-08-21 10:28:36 EDT
In F7 (in updates-testing and updates), we have the new taglib-based ID3 muxer.
Any chance you could give a try to F7 or rawhide?
Comment 8 Rodd Clarkson 2007-08-21 19:37:35 EDT
ah, I've had a look but can't see what package you're referring to.  Happy to
give it a try if you could tell me the package name.
Comment 9 Bastien Nocera 2007-08-21 19:48:09 EDT
Upgrade gstreamer-plugins-good, gstreamer-plugins-base, gstreamer and rhythmbox.
I think it should do :)
Comment 10 Rodd Clarkson 2007-08-21 22:00:53 EDT
Seems to work now.  I changed the album year tag for a bunch of oggs and no
errors appear and it seems to have changed the file.

Looks good to me.

I'll let you resolve this accordingly.  Thanks!
Comment 11 Bastien Nocera 2007-08-22 08:43:00 EDT
Rocking. Closing as rawhide, as I believe the fix is actually in both
gstreamer-plugins-good and rhythmbox.

Note You need to log in before you can comment on or make changes to this bug.