This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 219183 - Task 'have node leave cluster' stops rgmanager on node, does not stop cman service or clvmd process
Task 'have node leave cluster' stops rgmanager on node, does not stop cman se...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 14:07 EST by Len DiMaggio
Modified: 2009-04-16 18:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 15:23:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2006-12-11 14:07:48 EST
Description of problem:
Task 'have node leave cluster' stops rgmanager on node, does not stop cman
service or clvmd process

Version-Release number of selected component (if applicable):
luci-0.8-25.el5
ricci-0.8-25.el5

How reproducible:
100%

Steps to Reproduce:
1. With a (fully) functioning cluster, select 'have node leave cluster' task for
a node via the luci web app
2. The rgmanager (clurgmgrd) is stopped on the node
3. But, the cman service and the clvmd process are not stopped
  
Actual results:
The node is still listed as green/active in the luci web app.

Expected results:
cman, rgmanager and clvmd should all be stopped when a node is removed from a
cluster.

Additional info:
Comment 1 Ryan McCabe 2006-12-11 15:03:23 EST
I can't reproduce this using the current tree. Which RHEL-5-Server tree are you
running?
Comment 2 Ryan McCabe 2006-12-11 15:09:24 EST
In the past, I've seen the rgmanager init script hang on the "stop" command. Any
chance this is going on here?
Comment 3 Len DiMaggio 2006-12-11 15:19:59 EST
My test systems are out of date - they're still runing 1102 - I installed the
latest luci/ricci recently - 0.8-25.el5 - are there newer versions? 

The same versions are here:

http://porkchop.devel.redhat.com/rel-eng/RHEL5-Server-20061207.4/tree-i386/Cluster/

I'll still update the systems today.
Comment 4 Len DiMaggio 2006-12-11 15:23:42 EST
Closing this bug until test server is updated - I'll retry and reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.