Bug 219188 - yum + python-2.5 broken
Summary: yum + python-2.5 broken
Status: CLOSED DUPLICATE of bug 219029
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-11 20:15 UTC by John Ellson
Modified: 2014-01-21 22:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 20:19:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2006-12-11 20:15:30 UTC
Description of problem:
Bottom line seems to be:
  AttributeError: YumAvailablePackageSqlite instance has no attribute 'pkgID'

Version-Release number of selected component (if applicable):
yum-3.0.1-3.fc7.noarch
python-2.5-2.fc7.i386

How reproducible:
100%

Steps to Reproduce:
1.yum install alchemist
2.
3.
  
Actual results:
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 441, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 194, in resolveDeps
    self.populateTs(test=1)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 735, in
downloadHeader
    local =  po.localHdr()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 464, in localHdr
    pkgname = os.path.basename(self.remote_path)
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 419, in _remote_path
    return self.returnSimple('relativepath')
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 66, in
returnSimple
    (self.pkgID,))
AttributeError: YumAvailablePackageSqlite instance has no attribute 'pkgID'


Expected results:


Additional info:

Comment 1 Jeremy Katz 2006-12-11 20:19:19 UTC

*** This bug has been marked as a duplicate of 219029 ***


Note You need to log in before you can comment on or make changes to this bug.