Bug 219206 - Crash in python 2.5 bsddb module
Crash in python 2.5 bsddb module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 16:44 EST by Richard Dawe
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: python-2.5-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-16 16:40:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My configuration file for planet (2.05 KB, application/octet-stream)
2006-12-11 16:44 EST, Richard Dawe
no flags Details
gdb backtrace (4.38 KB, text/plain)
2006-12-11 16:45 EST, Richard Dawe
no flags Details
valgrind log (70.53 KB, application/octet-stream)
2006-12-11 16:46 EST, Richard Dawe
no flags Details

  None (edit)
Description Richard Dawe 2006-12-11 16:44:27 EST
Description of problem:

I'm trying to run planet-2.0 with python-2.5. As soon as planet tries to open
its cache database using dbhash, python segfaults. It worked fine under python-2.4.

Version-Release number of selected component (if applicable):

python-2.5-3.fc7 (just built)

How reproducible:

Happens every time.

Steps to Reproduce:
1. Install planet-2.0-3.fc7.
2. Create the directory test/planet.
3. Put the attached config.ini in the test/planet directory.
4. Copy /usr/share/doc/planet-2.0/examples/*.tmpl into the test/planet directory.
5. Copy /usr/share/doc/planet-2.0/examples/basic/*.tmpl into the test/planet
directory.
6. Adjust the paths listed in config.ini to point at your directories. Point the
cache at test/cache. You don't need to create test/cache -- it's create
automatically.
7. cd test/planet && planet config.ini
  
Actual results:

python should segfault like this:

DEBUG:planet.runner:Socket timeout set to 20 seconds
INFO:planet.runner:Loading cached data
Segmentation fault

Expected results:

planet should download a bunch of feeds, which looks like this:

DEBUG:planet.runner:Socket timeout set to 20 seconds
INFO:planet.runner:Loading cached data
INFO:planet:Updating feed <http://search.cpan.org/rss/search.rss>
DEBUG:planet:Last Modified: 2006-12-11T21:42:09+00:00
DEBUG:planet:Items in Feed: 12
INFO:planet:Updating feed <http://news.com.com/2063-10786_3-0.xml>
DEBUG:planet:Items in Feed: 10
...
Comment 1 Richard Dawe 2006-12-11 16:44:27 EST
Created attachment 143338 [details]
My configuration file for planet
Comment 2 Richard Dawe 2006-12-11 16:45:24 EST
Created attachment 143340 [details]
gdb backtrace
Comment 3 Richard Dawe 2006-12-11 16:46:21 EST
Created attachment 143342 [details]
valgrind log
Comment 4 Richard Dawe 2006-12-15 16:35:41 EST
Mail from Philipp Knirsch on fedora-maintainers suggests a potential fix:

"Jeremy Katz wrote:
> This is just a heads up that I'm in the progress of getting python 2.5
> staged for the development tree.  At this point, I'm doing the build on
> the side and trying to get a good chunk of the Core packages rebuilt
> against it before pushing to the development tree itself.  I'm still
> hoping to be able to do the actual move over either later today or
> tomorrow (depending on how fast the Core build system decides to be)
>

Just ran a few tests with it today and the version in the tree and i got a nice
segfault when using the bsddb module:

import bsddb
db = bsddb.hashopen("/var/lib/rpm/Basenames", "r")

died on me. Simply installing the latest db4 and db4-devel and then rebuilding
python fixed it for me.

Read ya, Phil"
Comment 5 Jeremy Katz 2006-12-15 16:39:58 EST
Hopefully will be fixed with -6 in tomorrow's rawhide; can you try it then to
see if it's better?
Comment 6 Jindrich Novy 2006-12-16 09:18:34 EST
Confirmed that python-2.5-6.fc7 is now rebuilt against libdb-4.5.so. I haven't
test its functionality as I have FC6 on my box.
Comment 7 Richard Dawe 2006-12-16 16:40:27 EST
Yes, that works like a charm. Thanks!

Note You need to log in before you can comment on or make changes to this bug.