Bug 219226 - initscripts have problems with raidautorun due to changes in nash
initscripts have problems with raidautorun due to changes in nash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 18:40 EST by Michal Jaegermann
Modified: 2014-03-16 23:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.49-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 19:18:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-12-11 18:40:00 EST
Description of problem:

The current version of /etc/rc.d/rc.sysconfig has the following line:

[ -x /sbin/nash ] && echo "raidautorun /dev/md0" | nash --quiet

The problem is that this happens, for obvious reasons, before non-/
file system are mounted and if /usr happens to be one of these then
you are getting:

nash: error while loading shared libraries: libnash.so.6.0.3: cannot open shared
object file: No such file or directory

with clear consequences for raidautorun.

The catch is that libnash.so.6.0.3 lives in /usr/lib/ or /usr/lib64/.

Actually a list of nash libraries on /usr is quite impressive:
libnash.so.6.0.3
libparted-1.8.so.0
libpopt.so.0
libbdevid.so.6.0.3
libdhcp.so.1
libnl.so.1
libdhcp4client.so.1
libdhcp6client.so.1
libz.so.1

What nash here buys over bash which is linked with three libraries
total and none of them on /usr?

Actually behind all of that is that nash is now linked dynamic,
starting with nash-6.0-1, which makes for initrd twice the size
as before, compressed and uncompressed.  Not sure why this was done
but a changelog entry indicates that this was not an accident.
If nash was used because it was providing capabilities not available
without dynamic libraries like libparted and libbdevid then now this
is gone and replacements are not apparent.

Version-Release number of selected component (if applicable):
initscripts-8.48-1

How reproducible:
always in the circumstances as above
Comment 1 Bill Nottingham 2006-12-19 15:29:54 EST
Removed from 8.49-1.
Comment 2 Michal Jaegermann 2007-02-06 17:58:09 EST
This could be fixed in 8.49-1 but rawhide still sports
initscripts-8.48-1 from 2006-11-28.  Recent nash update to 6.0.6-5
does not help either.
Comment 3 Bill Nottingham 2007-04-16 19:18:36 EDT
Should be fixed in 8.51-1.

Note You need to log in before you can comment on or make changes to this bug.