Bug 219244 - Further fix for python-2.5
Further fix for python-2.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 219443 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 21:17 EST by Deji Akingunola
Modified: 2014-01-21 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 10:55:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2006-12-11 21:17:48 EST
Description of problem: I think you forgot to apply the fix below to
yum/update_md.py as you did to other affected files.

--- yum/update_md.py        2006-12-11 21:00:36.000000000 -0500
+++ yum/update_md.py.new    2006-12-11 21:04:49.000000000 -0500
@@ -24,7 +24,11 @@
 
 from yum.yumRepo import YumRepository
 
-from cElementTree import iterparse
+try:
+    from xml.etree import cElementTree
+except ImportError:
+    import cElementTree
+iterparse = cElementTree.iterparse
 
 
 class UpdateNoticeException(exceptions.Exception):


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-12-12 10:55:07 EST
Thanks; applied to upstream and the rawhide package.
Comment 2 Jeremy Katz 2006-12-12 22:22:08 EST
*** Bug 219443 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.