Bug 219252 - OpenOffice.org Impress Crashes after some time in outline view
OpenOffice.org Impress Crashes after some time in outline view
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 01:22 EST by Thomas Ramapuram
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4-5.5.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 03:57:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace 1 (3.75 KB, text/plain)
2006-12-13 03:07 EST, Thomas Ramapuram
no flags Details
Trace 2 (5.57 KB, text/plain)
2006-12-13 03:08 EST, Thomas Ramapuram
no flags Details
Trace 3 (4.83 KB, text/plain)
2006-12-14 00:24 EST, Thomas Ramapuram
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 43235 None None None Never
OpenOffice.org 69010 None None None Never

  None (edit)
Description Thomas Ramapuram 2006-12-12 01:22:23 EST
Description of problem:


Version-Release number of selected component (if applicable):
Desktop is: GNOME
libgcj version is: libgcj-4.1.1-30-i386
kernel is: Linux 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006 i686 i686
i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.5.3-i386
depth of root window:    24 planes
accessibility is: false
fedora release is: Fedora Core release 6 (Zod)

How reproducible:
The error is always reproducible.  However there are no exact steps to reproduce
it.  I just use Impress for around 5 minutes in outline mode and it crashes.

My machine is Intel Centrino with 1 GB of Ram.

Steps to Reproduce:
1. Open Impress in Outline mode.
2. Use for around 5 minutes
3. Usually get a dialogue box which I will attach below.
  
Actual results:


Expected results:


Additional info:

Dialogue Box after Crash:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/i810_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-30-i386
(V)    kernel is: Linux 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.5.3-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x53af28: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22f28
0x53bbbb: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23bbb
0xfc4420:  + 0x420 (__kernel_sigreturn + 0x0)
0xe6e57e: /usr/lib/openoffice.org2.0/program/nestedreg.uno.so + 0x657e
0xe70228: /usr/lib/openoffice.org2.0/program/nestedreg.uno.so + 0x8228
0xe553a8: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xe3a8
0xe55c65: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xec65
0xe51d75: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xad75
0xe4d18b: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x618b
0x353598a: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x7898a
0x3536169: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x79169
0x3536ab3: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x79ab3
0x6d732d8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x22d2d8
(MnemonicGenerator::RegisterMnemonic(String const&) + 0x98)
0x6d6497e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x21e97e
(Menu::CreateAutoMnemonics() + 0x5e)
0x833df15: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x2ecf15
(EditView::ExecuteSpellPopup(Point const&, Link*) + 0xd55)
0x8390bbe: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x33fbbe
(OutlinerView::ExecuteSpellPopup(Point const&, Link*) + 0x2e)
0x48f2a4d: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x13fa4d
0x48acc16: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xf9c16
0x6dc52cf: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x27f2cf
0x6dc7a0a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x281a0a
0x6dc7d4f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x281d4f
0x96a679: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x38679
0x68dc0c0: /usr/lib/libgtk-x11-2.0.so.0 + 0x1300c0
0x42936f0b: /lib/libgobject-2.0.so.0 + 0x8f0b (g_closure_invoke + 0x12b)
0x42947e83: /lib/libgobject-2.0.so.0 + 0x19e83
0x42949147: /lib/libgobject-2.0.so.0 + 0x1b147 (g_signal_emit_valist + 0x667)
0x42949539: /lib/libgobject-2.0.so.0 + 0x1b539 (g_signal_emit + 0x29)
0x69f0118: /usr/lib/libgtk-x11-2.0.so.0 + 0x244118
0x68d5563: /usr/lib/libgtk-x11-2.0.so.0 + 0x129563 (gtk_propagate_event + 0x183)
0x68d6767: /usr/lib/libgtk-x11-2.0.so.0 + 0x12a767 (gtk_main_do_event + 0x317)
0x675e0ea: /usr/lib/libgdk-x11-2.0.so.0 + 0x410ea
0x427a8342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x427ab31f: /lib/libglib-2.0.so.0 + 0x2e31f
0x427ab885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x943d11: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x11d11
0xe248a7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x518a7
(X11SalInstance::Yield(bool, bool) + 0x37)
0x6bdb598: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x95598
(Application::Yield(bool) + 0x68)
0x6bdb66c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9566c
(Application::Execute() + 0x3c)
0x7dca379: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x26379
(desktop::Desktop::Main() + 0x1779)
0x6be11ac: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b1ac
0x6be12b5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b2b5 (SVMain()
+ 0x35)
0x7dbba69: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17a69 (sal_main
+ 0x59)
0x7dbbaf4: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17af4 (main + 0x44)
0x425ebf2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x8048481: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x481
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x0082b000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x00110000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x008f3000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x002d4000)
	libdl.so.2 => /lib/libdl.so.2 (0x002ec000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00776000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x002f0000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00ee2000)
	libm.so.6 => /lib/libm.so.6 (0x00470000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00e0e000)
	libc.so.6 => /lib/libc.so.6 (0x00497000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x003b7000)
	/lib/ld-linux.so.2 (0x41c07000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2006-12-12 03:42:36 EST
The trace implies that it happens when making short cuts for the spell checking
dropdown menu, so what language do you run OOo under ? Simply en_US ? Or
someother one.

ExecuteSpellPopup looks very relevant, thinking back do you think there could be
a reproducable route to this crash from using the spell checking dropdown ?
Perhaps when selecting a specific misspelled word ?
Comment 2 Thomas Ramapuram 2006-12-13 03:07:28 EST
Created attachment 143497 [details]
Trace 1
Comment 3 Thomas Ramapuram 2006-12-13 03:08:25 EST
Created attachment 143498 [details]
Trace 2

The Trace of the second crash
Comment 4 Thomas Ramapuram 2006-12-13 03:13:30 EST
On fc6 I use English(USA) as my language.  I guess that is en_US.  On OOo I use
User Interface: Default
Locale Settings; Default

Default Languages for Document
Western: English(USA).

I would also like to note that my keyboard is United Kingdom

The first time it crashed I was just typing real fast.
The second time it crashed I right clicked a misspelt word for a spellcheck
dropdown.

I am not sure if both the crashes are the same bug.
Comment 5 Caolan McNamara 2006-12-13 05:52:18 EST
Strange to see such a cluster of problems on what is a default-looking GNOME and
no accessibility and no selinux setup. 

Is there anything unusual about your setup ? e.g. nfs home dir, or something
like that. Any prelink error messages or filesystem errors in /var/log/messages ? 
Comment 6 Thomas Ramapuram 2006-12-14 00:22:15 EST
I do not use an network files and I have not configured NFS.   I use smb client
to copy files from other systems.  The files that I user are on my local system.

I looked into /var/log/messages.  There are around 4 lines concerning gconfd.
They are as foll:
Dec 14 10:24:35 localhost gconfd (thomas-3098): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Dec 14 10:24:35 localhost gconfd (thomas-3098): Resolved address
"xml:readwrite:/home/thomas/.gconf" to a writable configuration source at position 1
Dec 14 10:24:35 localhost gconfd (thomas-3098): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Dec 14 10:24:37 localhost hcid[2187]: Default passkey agent (:1.8,
/org/bluez/applet) registered
Dec 14 10:24:38 localhost gconfd (thomas-3098): Resolved address
"xml:readwrite:/home/thomas/.gconf" to a writable configuration source at position 0


In the meantime Impress crashed again.  I am including the dump.
Comment 7 Thomas Ramapuram 2006-12-14 00:22:52 EST
I do not use an network files and I have not configured NFS.   I use smb client
to copy files from other systems.  The files that I user are on my local system.

I looked into /var/log/messages.  There are around 4 lines concerning gconfd.
They are as foll:
Dec 14 10:24:35 localhost gconfd (thomas-3098): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Dec 14 10:24:35 localhost gconfd (thomas-3098): Resolved address
"xml:readwrite:/home/thomas/.gconf" to a writable configuration source at position 1
Dec 14 10:24:35 localhost gconfd (thomas-3098): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Dec 14 10:24:37 localhost hcid[2187]: Default passkey agent (:1.8,
/org/bluez/applet) registered
Dec 14 10:24:38 localhost gconfd (thomas-3098): Resolved address
"xml:readwrite:/home/thomas/.gconf" to a writable configuration source at position 0


In the meantime Impress crashed again.  I am including the dump.  This time I
was closing the application.
Comment 8 Thomas Ramapuram 2006-12-14 00:24:11 EST
Created attachment 143593 [details]
Trace 3

This time I was closing Impress.
Comment 9 Caolan McNamara 2006-12-14 03:38:54 EST
all very strange, a lot of crashes in different places. But I'm not getting a
slew of similar reports which would normally be the case.
Comment 10 Caolan McNamara 2006-12-18 08:24:03 EST
This might be due to http://qa.openoffice.org/issues/show_bug.cgi?id=69010 where
there's a problem due to mishandling of the undo stack in outline view.

Let's give that a try for an update >= openoffice_org-2.0.4-5.5.10 and see if it
resolves this cluster of strangeness.
Comment 11 Caolan McNamara 2007-01-04 03:57:41 EST
I believe 2.0.4-5.5.10 does the right thing now, if not feel free to reopen

Note You need to log in before you can comment on or make changes to this bug.