Bug 219292 - tries to parse lpstat output without setting POSIX locale
tries to parse lpstat output without setting POSIX locale
Status: CLOSED DUPLICATE of bug 337631
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gimp-print (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 09:47 EST by Tim Waugh
Modified: 2008-05-06 04:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 04:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-12-12 09:47:10 EST
+++ This bug was initially created as a clone of Bug #219017 +++

Description of problem:
The printers configured by cups does not appear in the gimp print dialog

Version-Release number of selected component (if applicable):
gimp-print-cups-4.2.7-22
gimp-print-4.2.7-22
gimp-print-plugin-4.2.7-22
gimp-2.2.13-1.fc6
gimp-libs-2.2.13-1.fc6
gimp-print-utils-4.2.7-22

system-config-printer-libs-0.7.41-2.fc7
system-config-printer-0.7.41-2.fc7
libgnomeprint22-2.17.0-2.fc7
gnome-python2-gnomeprint-2.17.1-2.fc7
libgnomeprintui22-2.12.1-6
desktop-printing-0.19-19.fc7


How reproducible:


Steps to Reproduce:
1. configure a printer with cups
2. start gimp
3. try to print something
  
Actual results:
i have configured and shared a network printer (ipp).
there is no problem with fc6-final, the problem only exists in fc6-rawhide(fc7).

Expected results:


Additional info:

-- Additional comment from twaugh@redhat.com on 2006-12-11 10:58 EST --
I can't reproduce this.  Works fine here.

What does 'lpstat -s' say?

-- Additional comment from bugzilla@thebc.ch on 2006-12-11 11:08 EST --
$ lpstat -s
system default destination: Canon
device for Canon: ipp://192.168.100.6:631/printers/Canon


-- Additional comment from twaugh@redhat.com on 2006-12-12 09:14 EST --
What does 'locale' say?

-- Additional comment from bugzilla@thebc.ch on 2006-12-12 09:24 EST --
# locale
LANG=de_CH.UTF-8
LC_CTYPE="de_CH.UTF-8"
LC_NUMERIC="de_CH.UTF-8"
LC_TIME="de_CH.UTF-8"
LC_COLLATE="de_CH.UTF-8"
LC_MONETARY="de_CH.UTF-8"
LC_MESSAGES="de_CH.UTF-8"
LC_PAPER="de_CH.UTF-8"
LC_NAME="de_CH.UTF-8"
LC_ADDRESS="de_CH.UTF-8"
LC_TELEPHONE="de_CH.UTF-8"
LC_MEASUREMENT="de_CH.UTF-8"
LC_IDENTIFICATION="de_CH.UTF-8"
LC_ALL=

-- Additional comment from twaugh@redhat.com on 2006-12-12 09:46 EST --
Okay, I can reproduce this on FC-6 as well.

Fixed in CVS.
Comment 1 Phil Knirsch 2008-04-30 11:53:14 EDT
Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.