Bug 219311 - Missing developers documentation
Summary: Missing developers documentation
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
Keywords:
: 241224 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-12 15:56 UTC by David Juran
Modified: 2008-01-15 12:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 12:02:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Juran 2006-12-12 15:56:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
In ldap.h several functions have been marked as deprecated but this is not reflected in the man pages. One example is the function ldap_init() which according to the header file is deprecated and instead ldap_initialize() is suggested. This is however not mentioned in the ldap_init() man page and there is no documentation whatsoever about ldap_initialize() 
  There seem to be an (ancient) bug upstream regarding this issue at http://www.openldap.org/its/index.cgi/Documentation?id=2240


Version-Release number of selected component (if applicable):
openldap-2.3.27-4

How reproducible:
Always


Steps to Reproduce:
1.N/A


Actual Results:


Expected Results:


Additional info:

Comment 1 Adam Tkac 2007-05-28 12:07:03 UTC
*** Bug 241224 has been marked as a duplicate of this bug. ***

Comment 2 Adam Tkac 2007-05-28 12:08:20 UTC
Also ldap_sasl_bind is undocumented :(

-A-

Comment 3 Jan Safranek 2008-01-15 12:02:37 UTC
Please check man pages in rawhide - at least "man ldap_initialize" and "man
ldap_sasl_bind" is there.


Note You need to log in before you can comment on or make changes to this bug.