Bug 219312 - yum bind-chroot selinux-policy-strict
yum bind-chroot selinux-policy-strict
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 11:00 EST by Andrew W. Donoho
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 14:38:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew W. Donoho 2006-12-12 11:00:30 EST
Description of problem:

yum update fails.

--> Running transaction check
--> Processing Conflict: bind-chroot conflicts selinux-policy-strict < 2.2.0
--> Finished Dependency Resolution
Error: bind-chroot conflicts with selinux-policy-strict < 2.2.0


Version-Release number of selected component (if applicable):


How reproducible:
It has happened each time I've tried to yum update for the last 2 days.

Steps to Reproduce:
1. sudo yum update
2.
3.
  
Actual results:

[awd@Iorek ~]$ sudo yum update
Password:
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 370 kB    00:02     
################################################## 1391/1391
primary.xml.gz            100% |=========================| 1.5 MB    00:11     
################################################## 4841/4841
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for avahi-compat-howl to pack into transaction set.
avahi-compat-howl-0.6.15- 100% |=========================| 8.3 kB    00:00     
---> Package avahi-compat-howl.x86_64 0:0.6.15-1.fc6 set to be updated
---> Downloading header for openssh to pack into transaction set.
openssh-4.3p2-14.fc6.x86_ 100% |=========================|  34 kB    00:00     
---> Package openssh.x86_64 0:4.3p2-14.fc6 set to be updated
---> Downloading header for pygtk2-devel to pack into transaction set.
pygtk2-devel-2.10.3-3.fc6 100% |=========================|  45 kB    00:00     
---> Package pygtk2-devel.x86_64 0:2.10.3-3.fc6 set to be updated
---> Downloading header for ruby-mode to pack into transaction set.
ruby-mode-1.8.5.2-1.fc6.x 100% |=========================|  21 kB    00:00     
---> Package ruby-mode.x86_64 0:1.8.5.2-1.fc6 set to be updated
---> Downloading header for ruby to pack into transaction set.
ruby-1.8.5.2-1.fc6.x86_64 100% |=========================|  36 kB    00:00     
---> Package ruby.x86_64 0:1.8.5.2-1.fc6 set to be updated
---> Downloading header for avahi-compat-howl to pack into transaction set.
avahi-compat-howl-0.6.15- 100% |=========================| 8.3 kB    00:00     
---> Package avahi-compat-howl.i386 0:0.6.15-1.fc6 set to be updated
---> Downloading header for gnome-pilot-devel to pack into transaction set.
gnome-pilot-devel-2.0.15- 100% |=========================|  14 kB    00:00     
---> Package gnome-pilot-devel.x86_64 0:2.0.15-1.fc6 set to be updated
---> Downloading header for openssh-clients to pack into transaction set.
openssh-clients-4.3p2-14. 100% |=========================|  33 kB    00:00     
---> Package openssh-clients.x86_64 0:4.3p2-14.fc6 set to be updated
---> Package bind.x86_64 31:9.3.3-0.1.rc3.fc6 set to be updated
---> Downloading header for xorg-x11-server-Xorg to pack into transaction set.
xorg-x11-server-Xorg-1.1. 100% |=========================|  41 kB    00:00     
---> Package xorg-x11-server-Xorg.x86_64 0:1.1.1-47.2.fc6 set to be updated
---> Downloading header for ruby-libs to pack into transaction set.
ruby-libs-1.8.5.2-1.fc6.x 100% |=========================|  74 kB    00:00     
---> Package ruby-libs.x86_64 0:1.8.5.2-1.fc6 set to be updated
---> Downloading header for at to pack into transaction set.
at-3.1.8-84.fc6.x86_64.rp 100% |=========================|  16 kB    00:00     
---> Package at.x86_64 0:3.1.8-84.fc6 set to be updated
---> Downloading header for avahi-glib to pack into transaction set.
avahi-glib-0.6.15-1.fc6.i 100% |=========================| 8.2 kB    00:00     
---> Package avahi-glib.i386 0:0.6.15-1.fc6 set to be updated
---> Downloading header for ruby-devel to pack into transaction set.
ruby-devel-1.8.5.2-1.fc6. 100% |=========================|  22 kB    00:00     
---> Package ruby-devel.x86_64 0:1.8.5.2-1.fc6 set to be updated
---> Downloading header for libbeagle to pack into transaction set.
libbeagle-0.2.13-1.fc6.x8 100% |=========================| 9.7 kB    00:00     
---> Package libbeagle.x86_64 0:0.2.13-1.fc6 set to be updated
---> Downloading header for vino to pack into transaction set.
vino-2.13.5-6.fc6.x86_64. 100% |=========================|  18 kB    00:00     
---> Package vino.x86_64 0:2.13.5-6.fc6 set to be updated
---> Package bind-libs.x86_64 31:9.3.3-0.1.rc3.fc6 set to be updated
---> Downloading header for xorg-x11-drv-tdfx to pack into transaction set.
xorg-x11-drv-tdfx-1.3.0-2 100% |=========================| 3.9 kB    00:00     
---> Package xorg-x11-drv-tdfx.x86_64 0:1.3.0-2.fc6 set to be updated
---> Package libgsf.x86_64 0:1.14.1-7 set to be updated
---> Downloading header for gnome-pilot to pack into transaction set.
gnome-pilot-2.0.15-1.fc6. 100% |=========================|  28 kB    00:00     
---> Package gnome-pilot.i386 0:2.0.15-1.fc6 set to be updated
---> Downloading header for screen to pack into transaction set.
screen-4.0.3-1.fc6.x86_64 100% |=========================|  16 kB    00:00     
---> Package screen.x86_64 0:4.0.3-1.fc6 set to be updated
---> Package dhcp.x86_64 12:3.0.5-1.fc6 set to be updated
---> Downloading header for openssh-server to pack into transaction set.
openssh-server-4.3p2-14.f 100% |=========================|  35 kB    00:00     
---> Package openssh-server.x86_64 0:4.3p2-14.fc6 set to be updated
---> Downloading header for xorg-x11-drv-s3 to pack into transaction set.
xorg-x11-drv-s3-0.5.0-1.f 100% |=========================| 3.7 kB    00:00     
---> Package xorg-x11-drv-s3.x86_64 0:0.5.0-1.fc6 set to be updated
---> Downloading header for avahi to pack into transaction set.
avahi-0.6.15-1.fc6.x86_64 100% |=========================|  17 kB    00:00     
---> Package avahi.x86_64 0:0.6.15-1.fc6 set to be updated
---> Package dhclient.x86_64 12:3.0.5-1.fc6 set to be updated
---> Downloading header for evince to pack into transaction set.
evince-0.6.0-5.fc6.x86_64 100% |=========================|  28 kB    00:00     
---> Package evince.x86_64 0:0.6.0-5.fc6 set to be updated
---> Downloading header for xorg-x11-server-Xvfb to pack into transaction set.
xorg-x11-server-Xvfb-1.1. 100% |=========================|  30 kB    00:00     
---> Package xorg-x11-server-Xvfb.x86_64 0:1.1.1-47.2.fc6 set to be updated
---> Downloading header for openssh-askpass to pack into transaction set.
openssh-askpass-4.3p2-14. 100% |=========================|  32 kB    00:00     
---> Package openssh-askpass.x86_64 0:4.3p2-14.fc6 set to be updated
---> Downloading header for gnome-pilot to pack into transaction set.
gnome-pilot-2.0.15-1.fc6. 100% |=========================|  28 kB    00:00     
---> Package gnome-pilot.x86_64 0:2.0.15-1.fc6 set to be updated
---> Downloading header for avahi to pack into transaction set.
avahi-0.6.15-1.fc6.i386.r 100% |=========================|  17 kB    00:00     
---> Package avahi.i386 0:0.6.15-1.fc6 set to be updated
---> Package libgsf-devel.x86_64 0:1.14.1-7 set to be updated
---> Downloading header for pycairo to pack into transaction set.
pycairo-1.2.6-1.fc6.x86_6 100% |=========================| 3.3 kB    00:00     
---> Package pycairo.x86_64 0:1.2.6-1.fc6 set to be updated
---> Package bind-chroot.x86_64 31:9.3.3-0.1.rc3.fc6 set to be updated
---> Downloading header for pygtk2-codegen to pack into transaction set.
pygtk2-codegen-2.10.3-3.f 100% |=========================|  14 kB    00:00     
---> Package pygtk2-codegen.x86_64 0:2.10.3-3.fc6 set to be updated
---> Downloading header for nautilus-cd-burner to pack into transaction set.
nautilus-cd-burner-2.16.0 100% |=========================|  27 kB    00:00     
---> Package nautilus-cd-burner.x86_64 0:2.16.0-6.fc6 set to be updated
---> Downloading header for gnome-pilot-conduits to pack into transaction set.
gnome-pilot-conduits-2.0. 100% |=========================|  16 kB    00:00     
---> Package gnome-pilot-conduits.x86_64 0:2.0.15-1.fc6 set to be updated
---> Downloading header for pycairo-devel to pack into transaction set.
pycairo-devel-1.2.6-1.fc6 100% |=========================| 2.9 kB    00:00     
---> Package pycairo-devel.x86_64 0:1.2.6-1.fc6 set to be updated
---> Downloading header for swig to pack into transaction set.
swig-1.3.31-0.fc6.x86_64. 100% |=========================|  64 kB    00:00     
---> Package swig.x86_64 0:1.3.31-0.fc6 set to be updated
---> Package bind-utils.x86_64 31:9.3.3-0.1.rc3.fc6 set to be updated
---> Downloading header for avahi-glib to pack into transaction set.
avahi-glib-0.6.15-1.fc6.x 100% |=========================| 8.2 kB    00:00     
---> Package avahi-glib.x86_64 0:0.6.15-1.fc6 set to be updated
---> Downloading header for pygtk2-libglade to pack into transaction set.
pygtk2-libglade-2.10.3-3. 100% |=========================|  10 kB    00:00     
---> Package pygtk2-libglade.x86_64 0:2.10.3-3.fc6 set to be updated
---> Downloading header for pygtk2 to pack into transaction set.
pygtk2-2.10.3-3.fc6.x86_6 100% |=========================|  34 kB    00:00     
---> Package pygtk2.x86_64 0:2.10.3-3.fc6 set to be updated
--> Running transaction check
--> Processing Conflict: bind-chroot conflicts selinux-policy-strict < 2.2.0
--> Finished Dependency Resolution
Error: bind-chroot conflicts with selinux-policy-strict < 2.2.0

Expected results:

yum to get past the transaction test.

Additional info:
Comment 1 Andrew W. Donoho 2006-12-12 14:37:42 EST
It looks like there are two selinux-policy-strict packages installed on my system. 
selinux-policy-strict-2.4.6-1.fc6
selinux-policy-strict-1.27.1-2.27

This is apparently the root of the problem. I will close this bug.

Thank you for your attention,
Andrew

Note You need to log in before you can comment on or make changes to this bug.