Bug 219320 - Add alteration of rhnConfigChannel table to sat upgrade scripts.
Add alteration of rhnConfigChannel table to sat upgrade scripts.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Slagle
Corey Welton
:
Depends On:
Blocks: 173432
  Show dependency treegraph
 
Reported: 2006-12-12 11:17 EST by Ken Ganong
Modified: 2007-10-29 22:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 22:16:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-12-12 11:17:34 EST
The 500 change of rhnConfigChannel changes users data.
It is NOT completely a schema change.
It is NOT default data for a table.

However, it must be run on old satellites while they migrate their data to a new
version of satellite.
Comment 2 Mike McCune 2007-04-12 15:13:37 EDT
looks like an upgrade bug, giving to cperry
Comment 4 James Slagle 2007-05-11 15:30:46 EDT
this was included as part of the sat 500 upgrade script.

testplan
---------
1) using config channel mgmt sat feature, generate all combinations of data
(i.e., server import, local override, and normal).
2) upgrade scehma
3) config channels continue to work as before.
Comment 5 Corey Welton 2007-06-11 22:44:28 EDT
QA Verified, after upgrade the configuration work set in a 420 satellite appears
to have migrated correctly over after an upgrade to 500
Comment 6 Corey Welton 2007-06-18 11:36:12 EDT
release_pending
Comment 7 Brandon Perkins 2007-06-25 22:16:31 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.