Bug 219359 - Dead keys generated by ALT-Gr key kombinations doesn't work in Sun Java
Dead keys generated by ALT-Gr key kombinations doesn't work in Sun Java
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 14:34 EST by Uno Engborg
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 17:46:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program compiled with Sun jdk1.6 (1.98 KB, application/octet-stream)
2006-12-12 14:34 EST, Uno Engborg
no flags Details

  None (edit)
Description Uno Engborg 2006-12-12 14:34:27 EST
Description of problem:

If I try to write a tilde on my Swedish keyboard in Sun Java 6
nothing is typed if I use (xorg-x11-server-Xorg-1.1.1-47.fc6.i386.rpm).

It works fine in FC4


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Install jdk 6 from http://java.sun.com/javase/downloads/index.jsp
   Use binary version to avoid messing up your rpms. Make sure java and
   javac is first in your path. Set JAVA_HOME to point at your java
installationinstallation.

2. Use an international keyboard, i.e. a keyboard that have  separate alt and
alt-Gr keys.

3. Set language to swedish try to type a tilde. This character is typed by
holding down alt-gr and ^ then pressing space. Or pressing alt-gr ^ directly
followed by ^
  
Actual results:
No tilde shows up


Expected results:
Tilde should have been typed

Additional info:

I'm using a thinkpad 50e with intel i915. It doesn't seam to matter if I use the
new fancy AIGLX or not. I think to  it worked in an unpatched version of FC6
(with a prereleace of JDK1.6) but the functionionality seam to have bean lost in
after some patching. (It doesn't work on a fully patched system even if I run
the prerelease of JDK1.6 that once worked).

I have no problem writing a tilde in other applications.

I attach a small program, that shows the keyboard events as java sees them that
might be helpful when debugging.

Start it by typing:
java -jar test.jar

The jar file also contains the source code, in case you like to inspect it.
Comment 1 Uno Engborg 2006-12-12 14:34:27 EST
Created attachment 143429 [details]
test program compiled with Sun jdk1.6
Comment 2 Matěj Cepl 2007-12-10 04:22:48 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 3 Uno Engborg 2007-12-13 16:41:05 EST
It seam to work now with the latest version of Sun Java and the latest updates
to FC6, so it was probably Suns fault.  So, I suggest you close the bug even
though I havn't been able to test it with current versions of Fedora. I will
hopfully be able to test them this weekend, and in the unlikely event that
the bug reappears in new versions of fedora the bug could be reopened.
Comment 4 Matěj Cepl 2007-12-13 17:46:53 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.