Bug 219367 - Some language options are not translated to Swedish
Some language options are not translated to Swedish
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: comps (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Dennis Gregorovic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 14:58 EST by Jan Hedstrom
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 20:41:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hedstrom 2006-12-12 14:58:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
During the graphical install, Anaconda prompts for what additional language support the user wants to install on the system. If the user has selected to use Swedish for the install dialog, most of these language options are translated to Swedish but not all. The following languages are still listed in English:
Arabic
Faeroese
Galican
Gujarati
Hindi
Irish
Lithuanian
Telugu
Urdu

I hope that this can serve as a useful heads-up, perhaps we have missed the translation to other languages too. 

Version-Release number of selected component (if applicable):
RHEL 5 beta 2, CD image 1

How reproducible:
Always


Steps to Reproduce:
1. Boot from RHEL 5 Client beta 2 CD 1, press enter to use the graphical installer.
2. Select Swedish (or possibly another language) to be used for the installation dialog.
3. Go through the dialog windows until you are prompted for additional language support.

Actual Results:
Most languages are listed in Swedish but some with their English names. The list is alphabetcally sorted, but the different languages makes it difficult to find what you are looking for.

Expected Results:
All languages listed in Swedish, producing a list where every item is alphabetcally sorted.

Additional info:
Comment 1 Jeremy Katz 2006-12-15 11:16:13 EST
Swedish is a community translated language and there have been some changes
since we branched for rhel5.  The community translators don't tend to end up
translating on rhel branches.

And these strings are from comps-po.
Comment 2 Jan Hedstrom 2006-12-15 18:21:41 EST
Oh, I was afraid that this was the case...
Two questions:
1. Will the updated translations be branched again for a RHEL 5 update, like 5.1.0?

2. How/where can I help the community translators? A pointer to the correct web
page/mailing list would be most welcome. 

Thanks,
/Jan
Comment 3 Dennis Gregorovic 2006-12-22 12:01:32 EST
I don't think branching is an issue here since the comps-po files don't get
branched.  Looking at the cvs log of comps-po/sv.po, there haven't been any
translations since Oct 4.  I don't know how to ask the community to focus on any
particular piece needing translation.
Comment 4 Dennis Gregorovic 2007-01-23 15:27:50 EST
in comps-po:
$ msgfmt -v --statistics -o /dev/null sv.po 
260 translated messages.
Comment 5 RHEL Product and Program Management 2007-01-23 15:41:46 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 RHEL Product and Program Management 2007-02-07 20:41:26 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.