Bug 219397 - misapplied patch in NFS client
misapplied patch in NFS client
Status: CLOSED DUPLICATE of bug 321101
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Staubach
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 17:13 EST by Chuck Lever
Modified: 2008-02-07 11:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 11:41:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix application of misapplied patch in NFS client (1.80 KB, patch)
2006-12-12 17:13 EST, Chuck Lever
no flags Details | Diff
fix file size revalidation logic (4.47 KB, patch)
2006-12-12 17:20 EST, Chuck Lever
no flags Details | Diff
use jiffies as the inode change attribute value (2.76 KB, patch)
2006-12-12 17:21 EST, Chuck Lever
no flags Details | Diff
missed a spot (1018 bytes, patch)
2006-12-12 17:22 EST, Chuck Lever
no flags Details | Diff
save attribute cache after end_data_update (12.55 KB, patch)
2006-12-13 18:54 EST, Chuck Lever
no flags Details | Diff
fix for previous patch (1.96 KB, patch)
2006-12-13 18:55 EST, Chuck Lever
no flags Details | Diff
another cache consistency regression (8.02 KB, patch)
2006-12-13 18:57 EST, Chuck Lever
no flags Details | Diff

  None (edit)
Description Chuck Lever 2006-12-12 17:13:50 EST
Description of problem:
A patch was misapplied to the NFS client in RHEL 4 update 3.  The patch adds a
function which is not used, and results in extra GETATTRs on the wire.

Version-Release number of selected component (if applicable):
kernel 2.6.9-34.EL

How reproducible:
Run connectathon suite -- happens every time.
Comment 1 Chuck Lever 2006-12-12 17:13:50 EST
Created attachment 143457 [details]
fix application of misapplied patch in NFS client
Comment 2 Chuck Lever 2006-12-12 17:20:41 EST
Created attachment 143458 [details]
fix file size revalidation logic
Comment 3 Chuck Lever 2006-12-12 17:21:55 EST
Created attachment 143459 [details]
use jiffies as the inode change attribute value
Comment 4 Chuck Lever 2006-12-12 17:22:51 EST
Created attachment 143460 [details]
missed a spot
Comment 5 Chuck Lever 2006-12-12 17:25:32 EST
Added three additional patches... these make the usage of nfs_update_inode()
consistent between nfs_refresh_inode() and __nfs_revalidate_inode().  The update
3 version of nfs_refresh_inode() was using fattr->time_start as a verifier,
while __nfs_revalidate_inode() was using an inode change attribute, which is not
a time-based value.
Comment 6 Chuck Lever 2006-12-13 18:54:22 EST
Created attachment 143581 [details]
save attribute cache after end_data_update
Comment 7 Chuck Lever 2006-12-13 18:55:03 EST
Created attachment 143582 [details]
fix for previous patch
Comment 8 Chuck Lever 2006-12-13 18:57:36 EST
Created attachment 143583 [details]
another cache consistency regression

I ported three additional mainline patches to RHEL 4 update 4.	This completes
the fix for this bug.  I split the patches out to document the source of each
fix.
Comment 12 RHEL Product and Program Management 2006-12-21 11:04:40 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 Peter Staubach 2008-02-07 11:41:20 EST
I think that this situation should be addressed by the changes for
bz321101.  That bug describes the fact that the RHEL-4 client issues
many more operations over the wire than does RHEL-3.

*** This bug has been marked as a duplicate of 321101 ***

Note You need to log in before you can comment on or make changes to this bug.