Bug 219414 - Terabyte sized partitions are shown with a "strange" size
Terabyte sized partitions are shown with a "strange" size
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
: 220384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 17:56 EST by Andreas Thienemann
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 09:50:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing disk druid (63.10 KB, image/png)
2006-12-12 17:56 EST, Andreas Thienemann
no flags Details
Showing the problem from comment 3 (74.18 KB, image/png)
2006-12-12 18:11 EST, Andreas Thienemann
no flags Details

  None (edit)
Description Andreas Thienemann 2006-12-12 17:56:18 EST
During disk druid a partition in a Logical Volume with about 1.2TB is shown as
having a size as 1.21853e+06.

It would be grat, if this size could be shown in a more human readable format.
Especially as the Volume Group is shown as 1220512 MB.

Please see the attached screenshot for an illustration.
Comment 1 Andreas Thienemann 2006-12-12 17:56:18 EST
Created attachment 143475 [details]
Screenshot showing disk druid
Comment 2 Andreas Thienemann 2006-12-12 18:11:24 EST
Created attachment 143478 [details]
Showing the problem from comment 3
Comment 3 Andreas Thienemann 2006-12-12 18:15:26 EST
Furthermore, if one is adding a new LVM partition disk druid is suggesting a
partition size in the e+06 notation.

This size notation is however rejected by the installer.
Comment 4 Chris Lumens 2006-12-22 10:49:21 EST
*** Bug 220384 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2007-01-04 15:19:32 EST
I've modified this in the devel branch.  If we need to get this done in RHEL5 as
well, we'll need to set the appropriate flags.  I don't know if it's too late to
get this in, though.

Note You need to log in before you can comment on or make changes to this bug.