Bug 219420 - ksh unaligned access messages
ksh unaligned access messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
: Reopened
Depends On:
Blocks: 253733
  Show dependency treegraph
 
Reported: 2006-12-12 18:40 EST by George Beshers
Modified: 2008-05-21 11:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2008-0326
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:43:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ksh93-unaligned.dif (292 bytes, patch)
2007-06-05 17:38 EDT, Tony Ernst
no flags Details | Diff

  None (edit)
Description George Beshers 2006-12-12 18:40:54 EST
Description of problem:

If ksh is running in a window and the window is resized
then unaligned access messages are generated, e.g.,

ksh(12697): unaligned access to 0x60000fffff6c343c, ip=0x400000000007d0f0
ksh(12697): unaligned access to 0x60000fffff6c343c, ip=0x400000000007d0f0
ksh(12697): unaligned access to 0x60000fffff6c343c, ip=0x400000000007d0f0
ksh(12697): unaligned access to 0x60000fffff6c343c, ip=0x400000000007d0f0

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.  Open a window on an Altix IA64 machine
2.  Run ksh
3.  Resize the window
  
Actual results:
Unaligned access messages.


Expected results:
No warnings.


Additional info:
Comment 2 Marizol Martinez 2007-04-17 16:19:19 EDT
George Beshers is working on other bugs related to this one (ie, reproducing
them and creating a fix). He has agreed to work on this one as well. Assigning
to him.
Comment 4 RHEL Product and Program Management 2007-06-05 16:46:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 5 Tony Ernst 2007-06-05 17:38:33 EDT
Created attachment 156282 [details]
ksh93-unaligned.dif

Reproducing this is easy (see above "Steps to Reproduce"), and the fix is
trivial.  I'm attaching the patch that was used to fix this bug in openSUSE
last year.

How do I "reopen this bugzilla for consideration in the next release"?	I don't
believe bugzilla will let me set this to the next release yet, will it?

Thank you.
Comment 6 Tomas Smetana 2007-06-06 08:19:18 EDT
Thanks for the patch. I've assigned the bug to myself and set flags for RHEL 5.2.
Comment 7 RHEL Product and Program Management 2007-10-19 16:32:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 George Beshers 2008-03-27 11:43:11 EDT
Partner Verified by SGI.
Comment 13 errata-xmlrpc 2008-05-21 11:43:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0326.html

Note You need to log in before you can comment on or make changes to this bug.