Bug 219448 - qt-devel RPM installs to /usr/lib/qt-3.3 instead of /usr/lib/qt
qt-devel RPM installs to /usr/lib/qt-3.3 instead of /usr/lib/qt
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
http://ktorrent.org/downloads/2.1beta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 00:05 EST by Marco Nadal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC6-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 11:04:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The config.log mentioned in the error message above (94.19 KB, text/plain)
2006-12-13 00:05 EST, Marco Nadal
no flags Details

  None (edit)
Description Marco Nadal 2006-12-13 00:05:01 EST
Description of problem:

qt-devel RPM installs to /usr/lib/qt-3.3 instead of /usr/lib/qt

Version-Release number of selected component (if applicable):

Group        : Development/Libraries
Source       : qt-3.3.7-0.1.fc5.src.rpm
Build Time   : Tue Oct 24 05:40:51 2006
Install Time : Wed Dec 13 14:29:05 2006
License      : GPL/QPL

How reproducible:
Very

Steps to Reproduce:
1. Try to ./configure a tarball that refers to the qt library. It will look for
it in the /usr/lib/qt directory, and report a file not found error.
2. Specifically, this occured with the ktorrent-2.1beta1.tar.gz.
  
Actual results:
checking for Qt... configure: error: Qt (>= Qt 3.3) (headers and libraries) not
found. Please check your installation!
For more details about this problem, look at the end of config.log.

Expected results:
Successful compile

Additional info:
Comment 1 Marco Nadal 2006-12-13 00:05:01 EST
Created attachment 143487 [details]
The config.log mentioned in the error message above
Comment 2 Ngo Than 2007-04-23 11:04:43 EDT
The QT enviroments have been missing in the previous qt version. It's already 
fixed in qt-3.3.7-0.1.

Note You need to log in before you can comment on or make changes to this bug.