Bug 219450 - booc cannot find assembly on x86_64
booc cannot find assembly on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: boo (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 01:43 EST by John Mahowald
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 17:03:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the libdir issue. (1.94 KB, patch)
2007-02-11 04:55 EST, Eskil Bylund
no flags Details | Diff

  None (edit)
Description John Mahowald 2006-12-13 01:43:36 EST
Description of problem:

When running boo executables on x86_64, it errors out on Boo.Lang assemblies not
being found.

Version-Release number of selected component (if applicable): boo-0.7.6.2237-9.fc6

How reproducible: always


Steps to Reproduce:
1. yum install boo
2. booc
  
Actual results:

$ booc

** (/usr/lib/boo/booc.exe:6261): WARNING **: The following assembly referenced
from /usr/lib/boo/booc.exe could not be loaded:
     Assembly:   Boo.Lang.Compiler    (assemblyref_index=1)
     Version:    1.0.0.0
     Public Key: 32c39770e9a21a67
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/boo).


** (/usr/lib/boo/booc.exe:6261): WARNING **: Could not load file or assembly
'Boo.Lang.Compiler, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=32c39770e9a21a67' or one of its dependencies.

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or
assembly 'Boo.Lang.Compiler, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=32c39770e9a21a67' or one of its dependencies.



Expected results:
Run booc.

Additional info: see URL for another report.
Comment 1 Paul F. Johnson 2006-12-17 08:29:02 EST
Thanks - should be an easy enough one to fix.
Comment 2 Paul F. Johnson 2006-12-20 17:03:32 EST
Should be fixed in the next push
Comment 3 Eskil Bylund 2007-02-11 04:55:10 EST
Created attachment 147850 [details]
Patch to fix the libdir issue.

Boo is still unusable on x86_64 since the scripts in /usr/bin use the wrong
libdir.

Note You need to log in before you can comment on or make changes to this bug.