Bug 219473 - "host" command from bind-utils package returns zero whether the host resolves or not.
"host" command from bind-utils package returns zero whether the host resolves...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.4
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 08:41 EST by Martin Hamant
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0743
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:03:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
very simple patch (779 bytes, patch)
2007-02-07 12:24 EST, Adam Tkac
no flags Details | Diff

  None (edit)
Description Martin Hamant 2006-12-13 08:41:18 EST
Description of problem:

"host" command from bind-utils package returns zero wether the host resolves or not.

Version-Release number of selected component (if applicable):

bind-utils-9.2.4-16.EL4

How reproducible:


Steps to Reproduce:

# host nawaktruc.fr
Host nawaktruc.fr not found: 3(NXDOMAIN)
# echo $?
0

# host truc.fr
truc.fr has address 194.116.144.27
# echo $?
0


Expected results:

It should returns "1" when not found ?
Comment 1 Martin Stransky 2007-01-30 09:14:53 EST
Please direct this request to BIND upstream (http://www.isc.org/index.pl?/sw/bind/)
Comment 2 Martin Hamant 2007-02-07 03:16:24 EST
Sorry, i forgot to mention that bug doesn't happen on my ubuntu (9.3.2)...
I can direct this to BIND upstream but they wont fix code for 9.2.4 !
Comment 3 Martin Stransky 2007-02-07 07:02:09 EST
I see. Okay, I'll check it.
Comment 4 Adam Tkac 2007-02-07 12:24:53 EST
Created attachment 147575 [details]
very simple patch

Yes, this "bug" really exists. I think upstream doesn't want patch it because
patch is really simple
Comment 6 RHEL Product and Program Management 2007-05-09 04:32:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 13 errata-xmlrpc 2007-11-15 11:03:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0743.html

Note You need to log in before you can comment on or make changes to this bug.