Bug 219529 - mount not trying all file systems in /proc/filesystems
mount not trying all file systems in /proc/filesystems
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-12-13 14:14 EST by frank a. madero
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-14 17:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace of mount (9.82 KB, text/plain)
2006-12-13 14:14 EST, frank a. madero
no flags Details
fat.img (1.41 MB, application/octet-stream)
2006-12-14 11:34 EST, frank a. madero
no flags Details

  None (edit)
Description frank a. madero 2006-12-13 14:14:48 EST
Description of problem:
When using the "mount" command to mount a floppy, the command fails to try all
nodev filesystems in /mount/proc. 

Version-Release number of selected component (if applicable):
mount (util-linux 2.13-pre6)

How reproducible:
mount /dev/floppy-fd0 /mnt/usbdisk

Steps to Reproduce:
Actual results:
mount: you must specify the filesystem type

Expected results:
a mounted filesystem

Additional info:
I did an strace on the command and I am attaching the results.  It clearly shows
a single attempt to mount the floppy with a filesystem and then stops and
according to the man page on mount "All of the filesystem types listed there
will be tried, except for those that are labeled "nodev"...", "there" meaning
/proc/filesystems.  I compared this strace to another on a different distro and
it tries different filesystems before quiting, thus sticking to the man page.
Comment 1 frank a. madero 2006-12-13 14:14:48 EST
Created attachment 143546 [details]
strace of mount
Comment 2 frank a. madero 2006-12-13 14:18:06 EST
I am sorry the description should read "... /proc/filesystems ..." not "...
/mount/proc ..."
Comment 3 Karel Zak 2006-12-13 16:08:56 EST
Which filesystem do you have on your device?
Comment 4 frank a. madero 2006-12-13 17:47:56 EST
fat on the floppy, it reads perfect on another distrobution as well as windows.
here is some more input:

[fmadero@esci15-97 ~]$ cat /proc/filesystems 
nodev   sysfs
nodev   rootfs
nodev   bdev
nodev   proc
nodev   cpuset
nodev   binfmt_misc
nodev   debugfs
nodev   securityfs
nodev   sockfs
nodev   usbfs
nodev   pipefs
nodev   futexfs
nodev   tmpfs
nodev   inotifyfs
nodev   eventpollfs
nodev   devpts
nodev   ramfs
nodev   hugetlbfs
nodev   mqueue
nodev   autofs
[fmadero@esci15-97 ~]$ cat /etc/filesystems
Comment 5 Karel Zak 2006-12-14 07:00:39 EST
The mount command uses unknown things from /proc/filesystems only. The vfat
should be tested in previous step. 

Please, I need more information:

# ls -la /dev/floppy-fd0
# blkid /dev/floppy-fd0

From the strace output it seems like an old FAT floppy without a magic string in
superblock. Please, send me image of this disk:

# cat /dev/floppy-fd0 > fat.img; bzip2 fat.img
Comment 6 frank a. madero 2006-12-14 11:34:59 EST
Created attachment 143655 [details]
Comment 7 frank a. madero 2006-12-14 11:36:52 EST
[root@esci15-97 util-linux-2.13-pre7]# ls -la /dev/floppy-fd0 
lrwxrwxrwx 1 root root 3 Dec 12 17:58 /dev/floppy-fd0 -> fd0

[root@esci15-97 util-linux-2.13-pre7]# blkid /dev/floppy-fd0 
[root@esci15-97 util-linux-2.13-pre7]# 
Comment 8 frank a. madero 2006-12-14 17:19:15 EST
The floppy I was using for the testing was working fine, I was able to mount it
on other operating systems: linux, windows, etc... Today when trying to test it
again on other operating systems found out it was not working any more, I don't
know when this failure in the floppy occurred.

Hence all seems to be working great, sorry for wasting anyone's time.  I still
think it was strange how within a span of a few minutes fedora couldn't mount a
fat floppy yet gentoo and windows were able, anyway it works now. I will
continue to moniter 'mount' on this box, after dredging through mount.c, and
mount_guess_fstype.c I know what functions to step through if a problem like
this occurs again.


Note You need to log in before you can comment on or make changes to this bug.