Bug 219571 - HTTP Error 401 with yum-rhn-plugin
HTTP Error 401 with yum-rhn-plugin
Status: CLOSED DUPLICATE of bug 217706
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
high Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 19:05 EST by Lars Herrmann
Modified: 2007-03-27 00:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 12:20:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Herrmann 2006-12-13 19:05:22 EST
Description of problem:
rhn-yum-plugin with webqa stopped working in the middle of a large update run
over slow line.

yum output:
https://xmlrpc.rhn.webqa.redhat.com/XMLRPC/GET-REQ/rhel-i386-client-5-beta/getPackage/httpd-2.2.3-6.el5.i386.rpm:
[Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.
https://xmlrpc.rhn.webqa.redhat.com/XMLRPC/GET-REQ/rhel-i386-client-5-beta/getPackage/pykickstart-0.42-1.el5.noarch.rpm:
[Errno 14] HTTP Error 401: Authorization Required
Trying other mirror.

This happened after downloading one package seemed to be stalled - perhaps due
to tcp timeouting (bad line).

But it should never show 401 errors and instead continuing downloading package
again or next package. Now he whole session seems to be whacked.

[root@x31 ~]# rpm -q yum-rhn-plugin yum
yum-rhn-plugin-0.2.0-2.el5
yum-3.0-5.4
Comment 1 James Bowes 2007-01-15 12:20:29 EST

*** This bug has been marked as a duplicate of 217706 ***

Note You need to log in before you can comment on or make changes to this bug.