Bug 219606 - SELinux irqbalance denial occurs every few seconds
SELinux irqbalance denial occurs every few seconds
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
: 220178 220334 224194 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 07:45 EST by vfiend
Modified: 2009-06-27 11:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
irqbalance targeted selilnux policy (492 bytes, application/octet-stream)
2006-12-14 15:32 EST, Neil Horman
no flags Details

  None (edit)
Description vfiend 2006-12-14 07:45:55 EST
Summary
    SELinux is preventing /usr/sbin/irqbalance (irqbalance_t) "search" access to
    net (proc_net_t).

...

Additional Information:       

Source Context:               system_u:system_r:irqbalance_t
Target Context:               system_u:object_r:proc_net_t
Target Objects:               net [ dir ]
Affected RPM Packages:        irqbalance-0.55-2.fc6 [application]
Policy RPM:                   selinux-policy-2.4.6-7.fc6
Selinux Enabled:              True
Policy Type:                  targeted
MLS Enabled:                  True
Enforcing Mode:               Enforcing
Plugin Name:                  plugins.disable_trans
Host Name:                    icarus
Platform:                     Linux icarus 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10
12:34:46 EST 2006 x86_64 x86_64
Alert Count:                  76
Line Numbers:                 

Raw Audit Messages:           

avc: denied { search } for comm="irqbalance" dev=proc egid=0 euid=0
exe="/usr/sbin/irqbalance" exit=-13 fsgid=0 fsuid=0 gid=0 items=0 name="net"
pid=2186 scontext=system_u:system_r:irqbalance_t:s0 sgid=0
subj=system_u:system_r:irqbalance_t:s0 suid=0 tclass=dir
tcontext=system_u:object_r:proc_net_t:s0 tty=(none) uid=0
Comment 1 Neil Horman 2006-12-14 15:32:14 EST
Created attachment 143692 [details]
irqbalance targeted selilnux policy

here is the policy file for irqbalance to allow it to access the proc files it
needs to properly balance irq's
Comment 2 Daniel Walsh 2006-12-14 16:00:00 EST
Fixed in selinux-policy-2.4.6-13
Comment 3 Andrew Rechenberg 2006-12-15 15:25:44 EST
Where can we find 2.4.6-13?  I don't see it in updates-testing.

Thanks,
Andy.
Comment 4 Daniel Walsh 2006-12-18 14:26:07 EST
Sorry, I forgot to press the submit to forwarding button.  Should be there tonight.

I have also made it available on 

http://people.redhat.com/dwalsh/SELinux/FC6
Comment 5 Neil Horman 2006-12-19 10:23:22 EST
*** Bug 220178 has been marked as a duplicate of this bug. ***
Comment 6 Neil Horman 2006-12-20 10:55:03 EST
*** Bug 220334 has been marked as a duplicate of this bug. ***
Comment 7 Neil Horman 2007-01-24 13:04:48 EST
*** Bug 224194 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2007-08-22 10:12:40 EDT
Fixed in current release

Note You need to log in before you can comment on or make changes to this bug.