Bug 219629 - collect2: ld terminated with signal 11 [Segmentation fault]
collect2: ld terminated with signal 11 [Segmentation fault]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 10:29 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.17.50.0.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-23 04:38:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of failed build (72.72 KB, application/octet-stream)
2006-12-14 10:29 EST, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2006-12-14 10:29:41 EST
Description of problem:
ld aborted with a segfault when I tried to rebuild kdeutils-3.5.5 in Rawhide.

Version-Release number of selected component (if applicable):
binutils-2.17.50.0.8-1

How reproducible:
always
Comment 1 Karsten Hopp 2006-12-14 10:29:42 EST
Created attachment 143638 [details]
log of failed build
Comment 2 Jakub Jelinek 2006-12-18 10:04:04 EST
Caused by http://sources.redhat.com/ml/binutils/2006-11/msg00044.html
together with --as-needed.
Comment 3 Jakub Jelinek 2006-12-18 10:27:33 EST
Testcase:
echo 'int foo (int x) { return bar (x) + 1; }' | gcc -m64 -mcall-aixdesc -O2
-fpic -shared -xc - -o liba.so
echo 'int main (void) { return 0; }' | gcc -m64 -O2 -L. -o test -xc - -xnone
-Wl,--as-needed -la -Wl,--no-as-needed -lc
Comment 4 Jakub Jelinek 2006-12-23 04:38:02 EST
Should be fixed in binutils-2.17.50.0.8-2 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.