Bug 219652 - Some systems don't have microcode device
Some systems don't have microcode device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: microcode_ctl (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
: OtherQA
: 220252 (view as bug list)
Depends On: 237434
Blocks: 224432
  Show dependency treegraph
 
Reported: 2006-12-14 12:07 EST by Jon Masters
Modified: 2010-10-22 03:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHEA-2007-0657
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:48:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
suggested init script fix (598 bytes, patch)
2007-05-09 11:31 EDT, Gerd Hoffmann
no flags Details | Diff

  None (edit)
Description Jon Masters 2006-12-14 12:07:31 EST
Description of problem:

On at least one system I've encountered, the kernel microcode device doesn't
exist so microcode_ctl fails to load and wibbles loudly on boot.

Jon.
Comment 1 RHEL Product and Program Management 2006-12-14 12:20:34 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Jon Masters 2006-12-20 06:08:59 EST
*** Bug 220252 has been marked as a duplicate of this bug. ***
Comment 3 Jon Masters 2006-12-20 06:12:50 EST
Looks more like a xen issue - obviously the microcode device doesn't exist when
running under virt. So I need to handle that.

This is a low impact, non-serious bug that simply results in an unnecessary
error message (but it is noisy on boot).

Jon.
Comment 11 Gerd Hoffmann 2007-05-09 11:31:50 EDT
Created attachment 154406 [details]
suggested init script fix
Comment 12 Yan Li 2007-05-09 21:55:59 EDT
This problem is also seen on some systems with latest RHEL5 (Kernel 
2.6.18-8.1.3.el5xen), Domain0.
Comment 13 RHEL Product and Program Management 2007-05-10 13:28:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Jay Turner 2007-05-10 14:35:06 EDT
Which solution are we thinking about going with?  Fixing the kernel or just
hacking the initscript?
Comment 18 Don Zickus 2007-06-12 14:46:59 EDT
in 2.6.18-24.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 21 Jon Masters 2007-06-29 11:15:23 EDT
Changed to microcode_ctl, since this is really where this needed handling.

Jon.
Comment 26 errata-xmlrpc 2007-11-07 11:48:33 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0657.html

Note You need to log in before you can comment on or make changes to this bug.