Bug 219710 - iscsi_tcp does not handle digests corrrectly on big endien systems
Summary: iscsi_tcp does not handle digests corrrectly on big endien systems
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Andy Grover
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On: 809207
Blocks: 533192 501988 525215
TreeView+ depends on / blocked
 
Reported: 2006-12-14 21:09 UTC by Mike Christie
Modified: 2013-01-24 01:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-24 01:07:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix BE crc handling (667 bytes, patch)
2007-12-12 22:02 UTC, Mike Christie
no flags Details | Diff

Description Mike Christie 2006-12-14 21:09:57 UTC
Description of problem:

The iscsi digest is 32bits and so we should be using the appropriate be/le
macors to access it.

Current we just copy it off the network and compare it to what we calculated on
the host so we get mismatch errors.


Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Set either header or data digests in the iscsid.conf file

node.conn[0].iscsi.HeaderDigest = CRC32C,None
node.conn[0].iscsi.DataDigest = CRC32C,None

2. log in to a port
3.
  
Actual results:

Get lots of connection errors and cannot proceed with the login.

Expected results:

Should not get connection errors.

Additional info:

Comment 1 RHEL Product and Program Management 2006-12-14 21:25:54 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Mike Christie 2007-12-12 22:02:02 UTC
Created attachment 286251 [details]
fix BE crc handling

Fixes BE digest handling.

Upstream commit.
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=ef19454bd437b2ba14c9cda1de85debd9f383484

Comment 4 Mike Christie 2007-12-12 22:03:59 UTC
Putting this up for 5.2. I guess BE digests never worked and it was not a iscsi
issue, so there is probably not much chance of a regession. OTOH, it seems like
no one uses this feature, so we could probably wait until 5.3 if there is no time.

Comment 6 RHEL Product and Program Management 2008-03-07 20:19:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Mike Christie 2008-09-24 15:46:37 UTC
Data digests are broken for all archs due to some other bug, so pushing this to 5.4 as it requires more work than originally thought. Also we still have not had a user or vendor asking for data digests.

Comment 9 RHEL Product and Program Management 2009-02-16 15:31:39 UTC
Updating PM score.

Comment 10 Mike Christie 2009-06-13 02:35:33 UTC
Move to 5.5

Comment 15 RHEL Product and Program Management 2010-12-07 09:48:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.

Comment 16 RHEL Product and Program Management 2011-06-20 21:05:49 UTC
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.7 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.

Comment 17 RHEL Product and Program Management 2012-01-09 13:44:59 UTC
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.8 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.

Comment 19 RHEL Product and Program Management 2012-10-30 05:59:44 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.


Note You need to log in before you can comment on or make changes to this bug.