Bug 219756 - Can not build results package
Summary: Can not build results package
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-15 07:04 UTC by NIWA Hideyuki
Modified: 2008-07-16 21:58 UTC (History)
1 user (show)

Fixed In Version: 5.0.17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 11:25:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This file includes /var/hts/config.xml, /var/hts/plan.xml, and /var/hts/results.xml files. (273.98 KB, application/x-gzip)
2006-12-20 00:09 UTC, NIWA Hideyuki
no flags Details
This file includes /var/hts/config.xml, /var/hts/plan.xml, and /var/hts/results.xml files on hts-5.0.14. (134.53 KB, application/x-gzip)
2006-12-21 06:30 UTC, NIWA Hideyuki
no flags Details
hts-results-rpm.spec file (825 bytes, application/octet-stream)
2007-01-10 08:28 UTC, NIWA Hideyuki
no flags Details
package.log (6.91 KB, application/octet-stream)
2007-01-19 11:23 UTC, NIWA Hideyuki
no flags Details

Description NIWA Hideyuki 2006-12-15 07:04:07 UTC
Description of problem:
When the results package can be built, it occurs following error.

Version-Release number of selected component (if applicable):
RHEL5B2
hts-5.0-9.noarch.rpm

Steps to Reproduce:

# hts submit
writing results to /var/log/hts/--Tikanga4.92_ia64_results
copied attachment file localhost.localdomain.2006120474627.tar.bz2 for info test
copied attachment file localhost.localdomain.2006120474627.tar.bz2 for info test
copied attachment file localhost.localdomain.2006120704355.tar.bz2 for info test
copied attachment file localhost.localdomain.2006120704355.tar.bz2 for info test
copied attachment file localhost.localdomain.20061207225051.tar.bz2 for info test
copied attachment file localhost.localdomain.20061207225051.tar.bz2 for info test
cp: cannot stat `/usr/src/redhat/RPMS/noarch/hts-*.rpm': No such file or directory

Comment 1 Greg Nichols 2006-12-19 17:45:02 UTC
Please provide the /var/hts/config.xml, /var/hts/plan.xml, and
/var/hts/results.xml files produced by HTS.

Thanks!
- Greg Nichols

Comment 2 NIWA Hideyuki 2006-12-20 00:09:48 UTC
Created attachment 144060 [details]
This file includes /var/hts/config.xml, /var/hts/plan.xml, and
/var/hts/results.xml files.

Comment 3 NIWA Hideyuki 2006-12-20 00:13:45 UTC
Hi, Greg.

I attached your required files.

Regard

Comment 4 NIWA Hideyuki 2006-12-21 06:30:39 UTC
Created attachment 144163 [details]
This file includes /var/hts/config.xml, /var/hts/plan.xml, and /var/hts/results.xml files on hts-5.0.14.

Comment 5 NIWA Hideyuki 2006-12-21 06:31:36 UTC
When the results package can be built by hts-5.0.14, it occurs following error
again.

# hts submit
writing results to /var/log/hts/--Tikanga4.92_ia64_results
copied attachment file localhost.localdomain.2006122122243.tar.bz2 for info test
copied attachment file localhost.localdomain.2006122122243.tar.bz2 for info test
copied attachment file localhost.localdomain.20061221113910.tar.bz2 for info test
copied attachment file localhost.localdomain.20061221113910.tar.bz2 for info test
copied attachment file localhost.localdomain.20061221141420.tar.bz2 for info test
copied attachment file localhost.localdomain.20061221141420.tar.bz2 for info test
cp: cannot stat `/usr/src/redhat/RPMS/noarch/hts-*.rpm': No such file or directory

I attached following files.
 package.log
 plan.xml
 config.xml
 results.xml

Regard

Comment 6 Greg Nichols 2007-01-09 20:56:10 UTC
Is the rpm-build package installed?   If not, could you try installing it?

Thanks!
Greg Nichols

Comment 7 NIWA Hideyuki 2007-01-10 08:26:54 UTC
Greg-san

Q)Is the rpm-build package installed?
A)Yes, it is installed rpm-build-4.4.2-33.el5.

By the way, I found why it can not build results package.
When RPM was constructed because information necessary for the following files
did not exist, it became an error. 

less /usr/share/hts/lib/hts-results-rpm.spec
              :
Release: %(expr `ls
/usr/src/redhat/RPMS/noarch/%{name}-%{version}-*[0-9].noarch.rpm | wc -l` + 1)
License: GPL
Vendor:<----------------------------- (1)
Group: Applications/System
Source: hts-results.tar.bz2
              :
              :


When the following commands are executed, enough information seems not to be 
obtained. 

#hts discover
sh: /usr/sbin/dmidecode: No such file or directory
Hardware:
OS: Tikanga 4.92
saved configuration to /var/hts/config.xml

Regard

Comment 8 NIWA Hideyuki 2007-01-10 08:28:38 UTC
Created attachment 145239 [details]
hts-results-rpm.spec file

Comment 9 Greg Nichols 2007-01-10 19:26:46 UTC
Thanks for the info, it was very helpful.  The problem is that 
hts did determine the vendor and model in its discover phase.
I've made a change so that it fills in "unknown" in these cases.

Fixed in R16.



Comment 10 NIWA Hideyuki 2007-01-19 11:23:10 UTC
Created attachment 145976 [details]
package.log

Comment 11 NIWA Hideyuki 2007-01-19 11:25:13 UTC
Greg-san

When the results package can be built by hts-5.0.17, it confirm to be fixed.

# hts submit
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
writing results to
/var/log/hts/American_Megatrends_Inc.-To_Be_Filled_By_O.E.M.-Tikanga4.92_x86_64_results
copied attachment file localhost.localdomain.20070119105730.tar.bz2 for info test
copied attachment file localhost.localdomain.20070119105730.tar.bz2 for info test
copied attachment file localhost.localdomain.20070119105835.tar.bz2 for info test
copied attachment file localhost.localdomain.20070119105835.tar.bz2 for info test
removing HTS logs ...
removing HTS logs done.
#
# ls /usr/src/redhat/RPMS/noarch/
hts-American_Megatrends_Inc.-To_Be_Filled_By_O.E.M.-Tikanga4.92_x86_64_results-1.noarch.rpm
#


Note You need to log in before you can comment on or make changes to this bug.