Bug 219771 - syslog-ng: update to version 2.0.x (from 1.6.12)
syslog-ng: update to version 2.0.x (from 1.6.12)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syslog-ng (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 05:58 EST by Jose Pedro Oliveira
Modified: 2008-01-18 11:49 EST (History)
2 users (show)

See Also:
Fixed In Version: syslog-ng-2.0.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 11:49:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2006-12-15 05:58:12 EST
This ticket will be used to keep track of possible problems and open issues
regarding the update of syslog-ng 1.6.x to 2.0.x.
Comment 1 Jose Pedro Oliveira 2006-12-15 06:12:55 EST
Syslog-ng 2.0.0 SRPM:
ftp://perl.di.uminho.pt/pub/fedora/syslog-ng-2.0.0-1.src.rpm


Open issues
-----------
* SELinux targeted policy and TCP sockets
  
  BUG 215046 (package syslog-ng)
  Targeted SELinux policy prevents syslog-ng from making tcp connections
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=215046

  BUG 218978 (package selinux-policy-targeted)
  syslog-ng unable to use TCP sockets
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218978


Things that have changed from syslog-ng version 1.6.11 to 2.0.0
---------------------------------------------------------------

* The default location of the configuration file has changed
  (from /etc/syslog-ng/syslog-ng.conf to /etc/syslog-ng)

  To be able to upgrade without any problems we have to use the
  configure option
      --sysconfdir=%{_sysconfdir}/syslog-ng

* the tcpwrapper support has been dropped

* the spoofing option has been dropped 


Other issues
------------

* The syslog provides is still needed

  It's required by the initscripts and the vixie-cron packages
  
  Bug 172885: syslog-ng gets removed when sysklod is updated
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172885
Comment 2 Jose Pedro Oliveira 2006-12-15 06:56:41 EST
Issue to check:

* [syslog-ng] Config parse error in syslog-ng 2.0.0
  https://lists.balabit.hu/pipermail/syslog-ng/2006-November/009558.html

Comment 3 Jose Pedro Oliveira 2006-12-15 09:10:21 EST
A couple of useful links:

* Syslog-ng roadmap
  http://www.balabit.com/products/syslog_ng/roadmap.bbq

* Linux.com: System Administration
  Interview: syslog-ng 2.0 developer Balázs Scheidler
  Wednesday December 13, 2006 (09:01 PM GMT)
  By: Robert Fekete
  http://www.linux.com/article.pl?sid=06/12/01/1756257
Comment 4 Jose Pedro Oliveira 2006-12-20 05:47:35 EST
* Bazsi's blog: Thoughts on the patent system
  http://bazsi.blogspot.com/2006/07/thoughts-on-patent-system.html

SOURCE: The above link appeared in the message:
https://www.redhat.com/archives/fedora-maintainers/2006-December/msg00125.html
Comment 5 Jose Pedro Oliveira 2007-01-04 12:17:11 EST
Syslog-ng 2.0.1 SRPM
ftp://perl.di.uminho.pt/pub/fedora/syslog-ng-2.0.1-1.src.rpm
Comment 6 Jose Pedro Oliveira 2007-01-06 11:35:37 EST
(In reply to comment #2)
> Issue to check:
> 
> * [syslog-ng] Config parse error in syslog-ng 2.0.0
>   https://lists.balabit.hu/pipermail/syslog-ng/2006-November/009558.html
> 

Problem still present in 2.0.1. See:

* [syslog-ng] syntax error
  https://lists.balabit.hu/pipermail/syslog-ng/2007-January/009695.html
Comment 7 Jose Pedro Oliveira 2007-01-07 12:06:55 EST
Migration: 1.6.x -> 2.0.x
-------------------------

Syslog-ng 1.6.x missing bits: --enable-tcp-wrapper  and  --enable-spoof-source

According to Balazs Scheidler the tcp_wrappers and spoofing support should be
added in the future:

 * [syslog-ng] Migration 1.6.x -> 2.0.x (missing bits)
   https://lists.balabit.hu/pipermail/syslog-ng/2007-January/009703.html
Comment 8 Jose Pedro Oliveira 2007-01-07 12:22:34 EST
(In reply to comment #6)
> (In reply to comment #2)
> > Issue to check:
> > 
> > * [syslog-ng] Config parse error in syslog-ng 2.0.0
> >   https://lists.balabit.hu/pipermail/syslog-ng/2006-November/009558.html
> > 
> 
> Problem still present in 2.0.1. See:
> 
> * [syslog-ng] syntax error
>   https://lists.balabit.hu/pipermail/syslog-ng/2007-January/009695.html
> 

More info, and possible patch correction for 2.0.1:

 https://lists.balabit.hu/pipermail/syslog-ng/2007-January/009701.html
Comment 9 Jose Pedro Oliveira 2007-01-20 12:18:37 EST
Another problem in syslog-ng 2.0.{0,1}:

* [syslog-ng] trailing spaces on udp messages (now with NULLs!)
  https://lists.balabit.hu/pipermail/syslog-ng/2007-January/009752.html
Comment 10 Jose Pedro Oliveira 2007-01-29 13:56:46 EST
Added Peter Vrabec to the CC list.

* syslog-ng 2.0.2 SRPM
  ftp://perl.di.uminho.pt/pub/fedora/syslog-ng-2.0.2-1.src.rpm

  Problems mentioned in comments #8 and in #9 should be solved.
  
  Problems mentioned in comment #1 still apply.

jpo
Comment 11 Jose Pedro Oliveira 2007-02-05 11:17:31 EST
Spoof-source status update

* [syslog-ng] spoof-source implemented
  https://lists.balabit.hu/pipermail/syslog-ng/2007-February/009842.html

* spoof-source added to 2.0.x 
  Saturday, February 03, 2007
  http://bazsi.blogspot.com/2007/02/spoof-source-added-to-20x.html

Comment 12 Jose Pedro Oliveira 2007-02-10 14:58:05 EST
Peter,

* Just built new eventlog RPMS with a -static subpackage for FC-5, FC-6, devel.

* Just imported and built syslog-ng 2.0.2 for devel.
 
  The current built static links glib2 and eventlog (BR: blib2-static and
  eventlog-static).

  TODO:
   i) For FC-6 and devel glib2 is installed in /lib. Try to link it dynamically.
  ii) Also try to install eventlog in /lib and have it linked dynamically.


jpo
Comment 13 Jose Pedro Oliveira 2007-02-11 20:35:24 EST
Already available in Fedora Extras mirrors:

  eventlog available for FC-5, FC-6, and devel
  --------------------------------------------
  eventlog-0.2.5-3.fc{5,6,7}.src.rpm
  eventlog-0.2.5-3.fc{5,6,7}.i386.rpm
  eventlog-devel-0.2.5-3.fc{5,6,7}.i386.rpm
  eventlog-static-0.2.5-3.fc{5,6,7}.i386.rpm


  syslog-ng 1.6.12 available for FC-5, and FC-6
  ---------------------------------------------
  syslog-ng-1.6.12-1.fc{5,6}.src.rpm
  syslog-ng-1.6.12-1.fc{5,6}.i386.rpm


  syslog-ng 2.0.2 available for devel
  ---------------------------------------------
  syslog-ng-2.0.2-1.fc7.src.rpm
  syslog-ng-2.0.2-1.fc7.i386.rpm

  Note: 2.0.2-1 statically linked against glib2 and eventlog
Comment 14 Jose Pedro Oliveira 2007-02-24 22:13:43 EST
eventlog: release bump in FC-6, and devel
--------------------------------------------
eventlog-0.2.5-4 now installs the dynamic library in /lib.


syslog-ng 2: release bump in devel
----------------------------------
syslog-ng-2.0.2-2 now uses the glib2 and the eventlog dynamic libraries
installed in /lib.  This works for Fedora Core 6 and above.

For previous versions you should build syslog-ng 2 with the the static
libraries of glib2 and of eventlog (the respective dynamic libraries are
installed in /usr/lib).
Comment 15 Jose Pedro Oliveira 2007-03-02 15:22:53 EST
tcp_wrappers support should be available in version 2.0.3.

Source: syslog-ng-2.0.2+20070302/ChangeLog
----------
...
2007-02-28 09:19:00 GMT  Balazs Scheidler <bazsi@balabit.hu>  patch-134

    Summary:
      implemented TCP wrapper support
    Revision:
      syslog-ng--mainline--2.0--patch-134
...
----------
Comment 16 Jose Pedro Oliveira 2007-03-09 14:01:36 EST
I have just finished building a new set of eventlog and syslog-ng RPMS for
Extras development:

  * eventlog-0.2.5-5.fc7
    no longer creates the -static subpackage

Build logs:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/28971-eventlog-0.2.5-5.fc7/

  * syslog-ng-2.0.3-0.20070309.fc7
    pushed the 20070309 snapshot in order to test the tcp_wrappers support
   (enabled by default) and also test the source address spoofing (disabled
   by default as it requires libnet; it was also disabled in syslog-ng 1.6.x).

Build logs:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/28974-syslog-ng-2.0.3-0.20070309.fc7/

Comment 17 Jose Pedro Oliveira 2007-03-30 16:00:49 EDT
Version 2.0.3 already available in the development branch

  * syslog-ng-2.0.3-1.fc7.src.rpm
  * syslog-ng-2.0.3-1.fc7.i386.rpm

This version now includes support for tcp_wrappers and spoofing (it now has the
 same 1.6.x features).
Comment 19 Jose Pedro Oliveira 2007-06-17 13:00:22 EDT
syslog-ng version 2.0.4 will cause a lot of problems due to the new
max_connections enforcing. See also:

  syslog-ng 2.0.4: Number of allowed concurrent connections exceeded; \
  num='10', max='10'
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241528


From the syslog-ng 2.0.4 NEWS file
----------------------------------
2.0.4
        Mon, 14 May 2007 11:47:48 +0200

        IMPORTANT NOTES:
        * This version of syslog-ng fixes a bug in enforcing the
          max-connections() limit for various stream-like sources
          (unix-stream and tcp). Previously this limit was not enforced,
          thus production environments may use an inadequate value.
          Validate your max-connection() settings before upgrading
          and check your logs for rejected connections.
...
----------

Right now syslog-ng 2.0.4 is available in the rawhide and in the F-7
updates-testing repositories.

jpo

Note You need to log in before you can comment on or make changes to this bug.