Bug 219776 - License incompatibility problem
License incompatibility problem
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All All
medium Severity high
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 07:37 EST by Thilo Pfennig
Modified: 2009-08-05 14:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-16 12:45:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thilo Pfennig 2006-12-15 07:37:50 EST
Description of problem:

Just to clear this. I see it a s a bug that fedora-websites are using the OPL.
Like here:  http://fedoraproject.org/wiki/Legal/Licenses

The problem is that this is a license that:
 a. The creators suggest NOT to use it (see
http://en.wikipedia.org/wiki/Open_Publication_License)
 b. Is not suggested to be used by the free software foundation
 c. Does not allow interchange with more popular licenses like GFDL or Creative
Commons.

This license resulted in an island solution for Red Hat/Fedora, which can not be
in the interest of the fedora project. This means that:

 a. Documentation progress is going to be slower as it could be
 b. You can not take parts of the Fedora documentation and put things in Wikipedia.

Goals for a new license:
 a. Should be widely used excepted
 b. Should allow content exchange with other projects like Wikipedia or other
distributions to be painless.
 c. Do not use licenses where the creators say, you should not use them.

I think the current solution is nearly as stupid as Suns decision to use the PDL
for the OpenOffice.org docs. Why does every project thinks it must have its own
license that nobody else uses? Well not really nobody but the project itself and
its sponsor. Fro  my persepctive this looks if some people want to strategically
dam up the spread of knowledge and documentation. And this is to be comdemned as
this is not in the FLOSS sense.

Possible workaround:

 * Publish under multiple licenses.

Please reconsider the licensing.
Comment 1 Rahul Sundaram 2006-12-15 08:48:24 EST
Some of the claims here need to be discussed further.

a. Other than the wikipedia reference which does have not any citation from the
author, do you have any authoritative reference about the author not
recommending the license? I could find any such information in
http://opencontent.org/openpub/

b. Your claim that FSF does not suggest using it is incorrect. You seem to be
confusing open publication license with the open content license which is a
non-free license. Fedora project does not use the restrictive OPL options as FSF
recommends. See
http://www.gnu.org/philosophy/license-list.html#FreeDocumentationLicenses

C. The GNU FDL itself is incompatible with creative commons license both ways.
So popularity of these licenses does not promote sharing of content.


We considered using both GNU FDL and creative commons. GNU FDL is a complex
license compared to OPL and has several known problems as explained in
http://people.debian.org/~srivasta/Position_Statement.xhtml. The choice of OPL
over creative commons attribution share alike license was due to the presence of
proper disclaimers in the former which is important from the legal perspective. 

The situation is not like Sun PDL since Fedora Project did not create its own
license but used one already in existence (see
http://www.wired.com/news/politics/0,1283,20276,00.html for more details) and
what was suitable for the project requirements.  This license is widely used by
several publications such as Oreilly, New Riders, education institutions,
organizations like Red Hat, VA Linux documentation project and so on. 


PS: The choice of license is clearly not a bug and bugzilla is not a right forum
for such discussions. Please consider taking this discussion to the fedora-docs
list instead. Thank you. 
Comment 2 Thilo Pfennig 2006-12-15 09:22:12 EST
a. I have seen such posts on http://opencontent.org/blog/. I think some of the
old posts (2003 or so) are now gone. You can see one post
http://opencontent.org/blog/archives/94 where he talks a bit about experiences
with OPL. But as you can see in this blog they only talk about and use CC
licenses now.

b. I am not confusing this because I know the differences. The FSF is not clear
- it say it CAN be used but it confuses people. Cite: "This creates a practical
pitfall in using or recommending this license: if you recommend ``Use the Open
Publication License, Version 1.0 but don't enable the options'', it would be
easy for the second half of that recommendation to get forgotten; someone might
use the license with the options, making a manual non-free, and yet think he or
she is following your advice."

c. This claim is incorrect. CC-BY-2.5 is not copyleft and can be relicensed as GFDL.

PS: I have found many bugs about false licenses in bugzilla. I consider this at
least an issue to be solved. Sure one can not discuss this here widely, but it
is an issue, still because it dirtectly affects the use of the documentation and
the work of the Fedora project.
Comment 3 Rahul Sundaram 2006-12-15 09:56:55 EST
a. I still dont see any authoritative reference from the author. Open
publication content license continues to be widely used in many places. 

b. We only use the OPL without options within Fedora and clarify this in all the
license notices very explicitly. The pitfall of using licenses where some
variant has restrictions apply to both GNU FDL itself and creative commons set
of licenses. (ie) they are not better in this matter. If FSF is not clear then
they should not be cited as a argument in this discussion. FSF does list books
licensed under open publication license without options as Free books and it is
listed a free documentation license. 

C. You cannot copy content freely between CC BY 2.5 and GNU FDL and there is no
inter sharing of content between them.  GNU GPL, FDL, CC-BY, OPL all have
different licensing terms and cannot form a common pool of content. If they were
mutually compatible with each other, there would be no point in dual licensing
content under these licenses.

To clarify, we choose the OPL without the options for the following reasons

* It is a Free documentation license and widely used. We did not want to create
our own project specific license. 
* It is simpler than GNU FDL and does have some of the commonly reported issues
with GNU FDL as referenced earlier. 
* It has proper attribution and other traits that are desirable in a license. It
has explicit disclaimers as opposed to CC licenses which is important as a legal
safeguard for authors. 

False licenses *are* bugs. This clearly is not a false license by any means even
if you have any potential problems with it.  We choose this license carefully
and deliberately. Kindly take this discussion to the mailing lists.  I would
suggest fedora-docs list or send a mail to the moderated fedora-advisory-board
list which has our legal counsel for input. Thanks. 
Comment 4 Paul W. Frields 2006-12-15 10:08:34 EST
The CC licenses also have distinct disadvantages, for example:

 * Irrevocability
 * Possible effective renunciation of copyright in some jurisdictions

In any case, Rahul is right that this discussion belongs on the
fedora-docs-list, especially before it gets escalated anywhere near the legal
counsel stage.  That queue is already quite full and this seems to me an issue
better dealt with by the community, since it is not based on any real legal concern.
Comment 5 Paul W. Frields 2006-12-15 10:15:54 EST
Reopening... didn't mean to shut off this conversation.
Comment 6 Thilo Pfennig 2006-12-16 12:45:06 EST
Don't bother. I give up on fedora.
Comment 7 eric@christensenplace.us 2009-08-05 14:43:02 EDT
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.

Note You need to log in before you can comment on or make changes to this bug.