Bug 219890 - X autoconfig confusion when multiple video cards present
X autoconfig confusion when multiple video cards present
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 17:49 EST by Raffaele Candeliere
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 09:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x log file from ananconda (11.62 KB, text/plain)
2007-01-22 07:39 EST, Raffaele Candeliere
no flags Details
X log file (38.60 KB, text/plain)
2007-01-22 07:40 EST, Raffaele Candeliere
no flags Details
another log file from X (41.76 KB, text/plain)
2007-01-22 07:41 EST, Raffaele Candeliere
no flags Details
one of the x configuration files tried (2.79 KB, text/plain)
2007-01-22 07:43 EST, Raffaele Candeliere
no flags Details
Another X configuration file (2.79 KB, text/plain)
2007-01-22 07:44 EST, Raffaele Candeliere
no flags Details
And yet another one (567 bytes, text/plain)
2007-01-22 07:45 EST, Raffaele Candeliere
no flags Details

  None (edit)
Description Raffaele Candeliere 2006-12-15 17:49:28 EST
Description of problem:
Well, i don't know how to describe the problem because i've tried so many
combination to lose memory of them.
I have an HP Kayak XA with an integrated Cirrus Logic (Laguna) GraphicAdapter
(on AGP) and a Voodo3 PCI card which i use as main display. I leave the on bord
adapter unused.
I'v been trying to update from FC4 to FC6 all the time but every effort has been
useless.
The graphical installer keeps on falling back in text mode (it detects ONLY the
on-board adapter, even if it is attached to no monitor, and not the actually
used adapter). "noprobe" and "skipddc" are useless. There is no way to tell the
istaller that i have a tdfx card. 
But apart from that i've tried to upgrade from FC4, to reinstall, to reformat
everithing, to kickstart and the evil knows what else but nothing!!!
The best result i managed to come to is a runlevel-3 with no X.
A telinit 5, in this case, makes the x-cursor appear and immediately disappear,
with X crashed.
What makes me crazy is the fact that the FC4 installer, even if NOT able to
detect the video card properly, start X fine and the entire installation process
flows smooth and easy (after which i can configure the correct video card with
the post-install helper).
I've tried to install FC6 on other machines also and i've meet very often the
same installation problems (the graphical installer fails and the text
installation process crashes somehow in the middle.)


Version-Release number of selected component (if applicable):


How reproducible:
Install an FC6 distribution on a system with an integrated (AGP) video-card and
an additional (PCI) video-card, leaving the vga-output of the on-board adapter
unconnected.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2007-01-04 16:29:59 EST
If X is crashing when you try to run it, this is probably not a bug specific to
the installer.  Sounds more like a bug in either the X server or your video card
driver.  Reassigning.
Comment 2 Matěj Cepl 2007-01-04 18:53:17 EST
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link
below.

Could you please try to run X without any /etc/X11/xorg.conf so that Xorg would
try to detect all settings automagically? Please attach both above mentioned
files from such attempt as well (you have to quit Xorg completely to make it to
write new /etc/X11/xorg.conf).

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 3 Raffaele Candeliere 2007-01-22 07:39:27 EST
Created attachment 146171 [details]
x log file from ananconda
Comment 4 Raffaele Candeliere 2007-01-22 07:40:50 EST
Created attachment 146172 [details]
X log file
Comment 5 Raffaele Candeliere 2007-01-22 07:41:58 EST
Created attachment 146174 [details]
another log file from X
Comment 6 Raffaele Candeliere 2007-01-22 07:43:36 EST
Created attachment 146175 [details]
one of the x configuration files tried
Comment 7 Raffaele Candeliere 2007-01-22 07:44:47 EST
Created attachment 146176 [details]
Another X configuration file
Comment 8 Raffaele Candeliere 2007-01-22 07:45:33 EST
Created attachment 146177 [details]
And yet another one
Comment 9 Raffaele Candeliere 2007-01-22 07:48:40 EST
 Ok. Let's try to explain things a bit more in details since i've had the
opportunity to spend a couple of days investigating the issue.
Well, i've taken a look at the X log file, both "with" and "without" the
xorg.conf file. The settings seem to be correct, at least for what is the
selection of the driver module ("tdfx").
Nevertheless i have the idea that the "unconnected" card ("cirruslogic") still
interfers.
But let us begin from the start.
When i start the installer (namly: anaconda), the "probe for display" phase
detects the cirrus logic card which has no monitor attached to, with X that
fails to start up and the installation procedure falling back to TextMode (see
attached anaconda.xlog).
Note that this happens already with FC5 while it doesn't happen with FC4 where X
starts perfectly even with the probe phase detecting the wrong card!
(In that case the "firstboot" utility gives me the chance to reconfigure
videocard and display bringing me to a perfectly working environment).
I've tried the installation also on a newer machine with only one videocard (but
i don't remember the exact hardware configuration), again, with X crashing  and
the installation process falling back to text mode. (In some cases  also the 
text installer crashes at some point in the middle of the copy process.
For example if i try to upgrade from FC4 to FC6, the text installer crashes at
some point in the middle of the file-copy phase with a message about "yum" -
"can't load yum" or something similar, i don't remember exactly -  shutting the
sistem down)
The installation process, in any case, goes somehow smooth and i get to a
working linux station at runlevel 3.
When i set the runlevel in the inittab file to 5 and i restart the system, the
rhgb hardly displays the "dna" on the screen when X crashes leaving mouse,
keybord and display frozen but with the startup phase still executing.
This brings me to the GDM splash screen which displays correctly (menus, text
box for the login user-name, etc.). At this point i'm able to run a "xterm"
session (by means of which i've been able to view and save the various log files).
Now, if i try to run a KDE or Gnome session, the process begins, the panels  and
splash windows are displayed but, when X starts drawing the icons ontop of the
desktop, it crashes bringing me  back to  the login screen.
The point when X crashes is only supposed since there's no time to see anything
on the screen but the panels, the mouse cursor, and the splash window. And not
only. A couple of times (but only a couple) during my attempts, i've been able
to reach a working Gnome desktop with some window open, but X crashed while
moving around some window.
At this point a "telinit 3" from "telinit 5" hangs the system with a keyboard
not responding and a mouse pointer frozen on a blank screen.
This is my best so far. Hope it helps for future versions

Regards

Raffaele Candeliere

Comment 10 Adam Jackson 2007-03-27 11:21:38 EDT
So it looks like anaconda is making the config file for the card that has VGA
routed (which is correct, i suppose), but then X is picking a primary based on,
I dunno, the I Ching or something.
Comment 11 Adam Jackson 2007-05-26 15:07:03 EDT
Reopening and moving to devel, this needs work.
Comment 12 Bug Zapper 2008-04-03 14:47:53 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 13 Raffaele Candeliere 2008-04-07 12:50:21 EDT
Sorry. I'm afraid i cannot help anymore. The machine with two videocards installed is no more in my 
possession. I have a new PC now with only one videcard so i cannot test if in case of multiple videocards, 
anaconda fails to recognise the one with the monitor attached.
The only thing i can say now is that the problem wasn't there in FC4 but showed up in FC5/6.
I hope to be more helpful in in other circumstances.

Thanks

Raffaele Candeliere
Comment 14 Matěj Cepl 2008-04-08 09:33:44 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.