Bug 219946 - Applications not quitting or redrawing correctly
Applications not quitting or redrawing correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj4-compat (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-17 11:06 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-16 13:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example code for the problem (594 bytes, text/x-java)
2006-12-17 11:06 EST, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2006-12-17 11:06:18 EST
Description of problem:
After compiling code and running, the application fails to close when the window
is terminated. Redraw events are also not being correctly handled

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp.111
gcc-4.1.1-47

How reproducible:
Always

Steps to Reproduce:
1. Compile the attached code and run from the command line
2.
3.
  
Actual results:
Application does not terminate (or redraw) correctly

Expected results:
Application should terminate as for any application and redraws occur

Additional info:
I've only just started using gcj, so these may not be bugs. If they're not, I'll
buy you a pint of something nice if you're in the NW of England at any point :-)
Comment 1 Paul F. Johnson 2006-12-17 11:06:18 EST
Created attachment 143868 [details]
Example code for the problem
Comment 2 Francis Kung 2007-03-15 11:51:42 EDT
I can't reproduce the redrawing bug; tested against libgcj-4.1.1-51 (latest in
FC6) and 4.1.2-3 (latest development package in rawhide).

The application not terminating is expected behaviour.  I believe you need to
add a window listener to handle the window close event and explicitly call
System.exit(), as otherwise there is an Event Queue thread that will continue to
run even after the window is closed.  This is the same behaviour as Sun's
virtual machine.

Note You need to log in before you can comment on or make changes to this bug.