Bug 219954 - gtk2reactor.py needs to be fixed on FC6
gtk2reactor.py needs to be fixed on FC6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-twisted (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-17 12:41 EST by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 19:31:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch that fixes problem for me (2.91 KB, patch)
2006-12-17 12:41 EST, Christopher Stone
no flags Details | Diff

  None (edit)
Description Christopher Stone 2006-12-17 12:41:26 EST
In FC5 gobject was built into the gtk module, now in FC6 gobject has been
seperated out into the pygobject2 rpm.  The gtk module in FC6 no longer supports
a gobject and gtk2reactor.py needs to be patched to accomodate this.

I am not sure on if this file has been fixed in FC7, but I know for a fact that
it is broken in FC6.

Please see attached patch.  To demonstrate what has changed try:

python
import gtk
gtk._gobject

on FC5 the above script will indicate it is included, in FC6+ an error occurs. 
The patch I have attached fixes python-twisted for FC6+ in this regard.  Please
communicate to upstream and apply updates to Fedora FC6, as I need this patch
for a package I am about to submit for review.
Comment 1 Christopher Stone 2006-12-17 12:41:26 EST
Created attachment 143871 [details]
Patch that fixes problem for me
Comment 2 Thomas Vander Stichele 2006-12-26 10:53:40 EST
the patch is probably not acceptable upstream since it will not be
backwards-compatible.

A better approach is probably to hide away the difference by trying to import
either gobject or gtk._gobject as a "gobject" global and then keep the code as is.
Comment 3 Christopher Stone 2006-12-26 11:08:48 EST
That sounds good to me.  My python is very rusty so I'm not sure how to do such
a patch.
Comment 4 Christopher Stone 2007-01-05 11:25:29 EST
This problem seems to be fixed in python-twisted-core package.
Comment 5 Christopher Stone 2007-01-24 19:31:56 EST
Closing bug, if there is any reason why this bug should not be closed, then
reopen explaining why or add a dependency.

Note You need to log in before you can comment on or make changes to this bug.