Bug 219985 - mcstransd denials
mcstransd denials
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-17 21:38 EST by Dave Jones
Modified: 2016-03-11 03:54 EST (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:14:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-12-17 21:38:05 EST
Dec 17 19:50:34 silver kernel: audit(1166406634.351:4): avc:  denied  { read }
for  pid=1580 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext=
system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Dec 17 19:50:34 silver kernel: audit(1166406634.379:5): avc:  denied  { read }
for  pid=1580 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext=
system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Dec 17 19:50:34 silver kernel: audit(1166406634.403:6): avc:  denied  { read }
for  pid=1580 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext=
system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Dec 17 19:50:34 silver kernel: audit(1166406634.427:7): avc:  denied  { read }
for  pid=1580 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext=
system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Dec 17 19:50:34 silver kernel: audit(1166406634.487:8): avc:  denied  { read }
for  pid=1581 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext=
system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Dec 17 19:50:34 silver kernel: audit(1166406634.515:9): avc:  denied  { read }
for  pid=1581 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext=
system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Dec 17 19:50:34 silver kernel: audit(1166406634.547:10): avc:  denied  { read }
for  pid=1581 comm="mcstransd" name="localtime" dev=dm-0 ino=3932186 scontext
=system_u:system_r:setrans_t:s0 tcontext=user_u:object_r:etc_t:s0 tclass=file
Comment 1 Daniel Walsh 2006-12-18 14:43:22 EST
restorecon /etc/localtime

The current policy should prevent this from happening in the future, since 
/usr/sbin/tzdata-update now has policy that says if it creates a file in etc_t
create it as localtime_t
Comment 2 Daniel Walsh 2007-08-22 10:14:37 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.