Bug 220013 - rpmlint errors on yumex.spec
Summary: rpmlint errors on yumex.spec
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-18 13:52 UTC by Laurent Rineau
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 14:58:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix %changelog (2.20 KB, patch)
2006-12-18 15:23 UTC, Laurent Rineau
no flags Details | Diff

Description Laurent Rineau 2006-12-18 13:52:20 UTC
***Description of problem:

rpmlint gives several errors about yumex:, and some of them should not be 
ignored:

On the noarch compiled package:
  E: yumex use-old-pam-stack /etc/pam.d/yumex (line 4)
  Update pam file to use include instead of pam_stack.

On the source package:
  W: yumex strange-permission yumex.spec 0755
  E: yumex hardcoded-library-path in /usr/lib/python?.?/site-packages/yumgui
  W: yumex macro-in-%changelog files
  W: yumex macro-in-%changelog files
  W: yumex macro-in-%changelog build_v

About hardcoded-library-path, you should use the trick recommended at 
http://fedoraproject.org/wiki/Packaging/Python :

%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}

and then use %{python_sitearch} instead of /usr/lib/python?.?/site-packages/

***Version-Release number of selected component (if applicable):
  - yumex-1.0.3-3.0.fc5,
  - yumex-1.9.0-1.0.fc6 (on your web site),
  - current devel: yumex-1.2.1-1.0.fc7.

Comment 1 Tim Lauridsen 2006-12-18 15:01:12 UTC
I have fixed the hardcoded path & the PAM error in yumex SVN branches
1.9.x & 1.2.x.

New version of 1.9.0-1.1 is uploaded.


Comment 2 Laurent Rineau 2006-12-18 15:23:48 UTC
Created attachment 143901 [details]
Patch to fix %changelog

(In reply to comment #0)
>   W: yumex macro-in-%changelog files
>   W: yumex macro-in-%changelog files
>   W: yumex macro-in-%changelog build_v

The attached patch also fix the macros in %changelog. The sign "%", in
%changelog, has to be quoted that way: "%%".

Comment 3 Tim Lauridsen 2007-01-03 14:58:29 UTC
1.9.x & 1.2.x are fixed in SVN



Comment 4 Laurent Rineau 2007-01-03 15:32:28 UTC
Will them appear in FE soon?


Comment 5 Tim Lauridsen 2007-01-03 15:42:36 UTC
1.9.1 will enter Extras Development, when i get some feedback on some python 2.5
issues.

1.2.1 allready released contains most of the rpmlint fixes, except the changlog
warnings.

Comment 6 Laurent Rineau 2007-01-03 15:52:09 UTC
Everbody seems to forgot FE-5. :-(
Thank you, anyway, I will compile the src.rpm from FE-6.


Comment 7 Laurent Rineau 2007-01-03 16:00:45 UTC
(In reply to comment #6)
> Everbody seems to forgot FE-5. :-(

Sorry, I failed to see the dependency form yum>=3.0.

(In reply to comment #5)
> 1.2.1 allready released contains most of the rpmlint fixes, except the 
changlog
> warnings.

Actually, you missed:
E: yumex hardcoded-library-path in /usr/lib/python?.?/site-packages/yumex
E: yumex hardcoded-library-path in /usr/lib/python?.?/site-packages/yumgui

This the result of rpmlint-0.78-2.fc5 on yumex-1.2.1-1.0.src.rpm .


Comment 8 Tim Lauridsen 2007-01-04 08:24:15 UTC
Ok, i checked again, it looks like then spec file changes has been made in 
yumex-1.2.1-1.1, i will request a new Extra Build very soon.  


Note You need to log in before you can comment on or make changes to this bug.