Bug 220046 - /usr/bin/fp conflict with fpc
/usr/bin/fp conflict with fpc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontypython (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Mohler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 12:02 EST by Gérard Milmeister
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 18:49:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2006-12-18 12:02:06 EST
/usr/bin/fp is a binary provided by the fpc package.
It would say, simply rename fp to fontypython.
(Two letter names for binaries are not a good idea anyway :-)
Comment 1 Chris Mohler 2006-12-18 14:42:51 EST
OK, I'll fix this tonight - thanks...
Comment 2 Chris Mohler 2006-12-18 20:14:13 EST
Just because I haven't been a member for long - an outline of the steps I've taken:

1 - did 'cvs up -dP' in my fedora-cvs dir.
2 - copied my modified spec file to devel,FC-6,FC-5
3 - 'cvs diff -u' - just to check.
4 - 'cvs commit'
5 - 'make tag && make build' in each branch.

I tested the spec file before starting the above - using it to create a SRPM and
building/installing in mock.

If I've overlooked anything, please let me know.



Comment 3 Chris Mohler 2006-12-19 10:33:29 EST
Damn.  The desktop file still uses the 'fp' name, so this package needs another
update.

Comment 4 Chris Mohler 2006-12-20 18:49:44 EST
OK - 0.2.0-6 seems to have done the trick.

Note You need to log in before you can comment on or make changes to this bug.