Bug 220061 - should not report wrong-file-end-of-line-encoding on PDF files
should not report wrong-file-end-of-line-encoding on PDF files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 13:37 EST by Remi Collet
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.79-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 11:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2006-12-18 13:37:45 EST
Description of problem:


Version-Release number of selected component (if applicable):
rpmlint-0.78-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. add a PDF ini %doc
2. run rpmlint
3.
  
Actual results:
For example
W: pdflib-lite wrong-file-end-of-line-encoding
/usr/share/doc/pdflib-lite-7.0.0p3/PDFlib-Lite-license.pdf


Expected results:
no warning

Additional info:
PDF example :
http://www.pdflib.com/fileadmin/pdflib/pdf/license/PDFlib-Lite-license.pdf
Comment 1 Ville Skyttä 2006-12-18 14:43:26 EST
Special case hack added upstream, will be in the next release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1302
Comment 2 Martin Ebourne 2006-12-29 09:30:50 EST
Might be a good idea to make this more generic. eg. .rtf files exhibit exactly
the same problem.
Comment 3 Ville Skyttä 2006-12-29 09:59:58 EST
There is already a generic check (roughly "read first 512 bytes of a file, check
if it contains any null chars or more than 30% non-text chars; if yes, it's
binary") - the problem is that it fails to identify PDF files as binary and thus
proceeds to do end-of-line checks on them. 
http://aspn.activestate.com/ASPN/Cookbook/Python/Recipe/173220
Comment 4 Martin Ebourne 2006-12-29 16:57:30 EST
Ok, but .rtf files still give the same error from rpmlint, so they obviously
need some kind of special handling as well then.

An example rtf which fails this check can be found in the package at
http://www2.zoneminder.com/downloads/ZoneMinder-1.22.3.tar.gz.
Comment 5 Ville Skyttä 2007-01-01 21:21:49 EST
Special handling for RTFs added upstream:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1304

There's probably a whole bunch of others that should be added too, eg. HTML.
Comment 6 Ville Skyttä 2007-02-02 11:06:32 EST
Done in upcoming 0.79-1.

Note You need to log in before you can comment on or make changes to this bug.