Bug 22008 - tcpdump: pcap_loop: poll: Interrupted system call
tcpdump: pcap_loop: poll: Interrupted system call
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-09 18:17 EST by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-22 10:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-12-09 18:17:34 EST
if you launch tcpdump and stop the process with CTRL-Z before anything is output,
you get interrupted system call error and tcpdump dies when you 'fg':

---
# /usr/sbin/tcpdump -n port not ssh
Kernel filter, protocol ALL, TURBO mode (575 frames), datagram packet socket
tcpdump: listening on all devices

[1]+  Stopped                 /usr/sbin/tcpdump -n port not ssh
# fg
/usr/sbin/tcpdump -n port not ssh
tcpdump: pcap_loop: poll: Interrupted system call
---

This works correctly after you have received something from the network 
and it has been output. If traffic is filtered out (e.g. port not ssh), it doesn't count.

This also works correctly with the same tcpdump rebuilt on RHL62.
Comment 1 Harald Hoyer 2001-01-22 10:12:11 EST
works for me with glibc-2.2-9 and kernel-2.2.16-22...
Comment 2 Pekka Savola 2001-01-22 10:37:14 EST
Hmm.  This only happens with 2.4.* kernels it seems.  Either the one in preview
directory
or Rawhide (kernel-2.4.0-0.43.12).

The difference seems to be TURBO mode in:

Kernel filter, protocol ALL, TURBO mode (575 frames), datagram packet socket



Note You need to log in before you can comment on or make changes to this bug.