Bug 220105 - RHNSat5: userlist |< < > >| buttons don't work
RHNSat5: userlist |< < > >| buttons don't work
Status: CLOSED DUPLICATE of bug 220106
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 17:13 EST by Matt Domsch
Modified: 2007-07-31 14:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 17:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-12-18 17:13:26 EST
Description of problem:
https://rhn.linuxdev.us.dell.com/rhn/users/ActiveList.do page shows buttons for
|< < > >| which are appropriately grayed or active, but clicking on the active 
buttons yields a list that is unchanged.  

The button marked ">" resolves to a URL:
https://rhn.linuxdev.us.dell.com/rhn/users/ActiveList.do?lower=1
but the list still starts from the top (I've got 65 active users, it should 
have shown me page 2).

Likewise the button for ">|" gives the same URL with "lower=1" on the end.

Typing in a different lower: value does solve it:
https://rhn.linuxdev.us.dell.com/rhn/users/ActiveList.do?lower=21

so merely the links provided by the buttons are being mis-calculated.


Version-Release number of selected component (if applicable):
rhn-satellite-4.9.0-14-redhat-linux-as-i386-4-embedded-oracle.iso

How reproducible:
always


Steps to Reproduce:
1. Go to the Users page
2. Click one of the previous or next page buttons

  
Actual results:
same page is produced starting from address 1

Expected results:
next page is produced.
Comment 1 Matt Domsch 2006-12-18 17:20:49 EST

*** This bug has been marked as a duplicate of 220106 ***

Note You need to log in before you can comment on or make changes to this bug.