Bug 220111 - hts sumbit not working after hts certify was run.
hts sumbit not working after hts certify was run.
Status: CLOSED DEFERRED
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Greg Nichols
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 17:30 EST by Garry Wong
Modified: 2007-04-18 13:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 13:10:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot png file (174.32 KB, image/x-png)
2006-12-18 17:30 EST, Garry Wong
no flags Details
/var/hts folder (2.89 KB, application/x-zip-compressed)
2006-12-19 14:29 EST, Garry Wong
no flags Details
hts submit error screen (184.28 KB, application/x-zip-compressed)
2007-01-10 10:12 EST, Garry Wong
no flags Details
virt log (5.27 KB, application/x-zip-compressed)
2007-01-16 10:41 EST, Garry Wong
no flags Details

  None (edit)
Description Garry Wong 2006-12-18 17:30:50 EST
Description of problem:

hts sumbit or hts certify command is no longer work after hts certify was run

Version-Release number of selected component (if applicable):

rhel5 hts version 5 release 14

How reproducible:


Steps to Reproduce:

1. Install rhel5 x86_64 beta2 with Virtualization capability onto system under 
test with VT or V enabled in BIOS
2. Install rhel5 x86 beta2 onto network test server
3. Install rhel5 hts version 5 release 14 test suite onto both system under 
test and network test server (with IPV4 status ip address 10.1.1.10)
4. On network test server ---> hts  server start
5. On system under test ----> hts plan ----> hts certify --test Virt --server 
10.1.1.10
6. After Virt test completed, type command "hts submit" and hit RETURN ----> 
the command "hts submit" not working. 

Actual results: The command " hts submit" is not working.

Expected results: The command "hts submit" should work as hts version 9 after 
hts tests run.



Additional info: see attached screenshot png file
Comment 1 Garry Wong 2006-12-18 17:30:51 EST
Created attachment 143954 [details]
Screenshot png file
Comment 2 Greg Nichols 2006-12-19 13:39:41 EST
please provide the config.xml, plan.xml and results.xml files located in the
/var/hts directory.

Thanks!
Comment 3 Garry Wong 2006-12-19 14:29:17 EST
Created attachment 144033 [details]
/var/hts folder

Attached is /var/hts folder contains xml files.

Thanks,
Comment 4 YangKun 2007-01-05 01:27:09 EST
Verified in hts-5.0-15, problem no longer exists.
Comment 5 Garry Wong 2007-01-10 10:12:58 EST
Created attachment 145258 [details]
hts submit error screen

I installed hts-5.0-15 --> ran virt test ---> then ran hts submit ---> hts
submit still not working (see attached).
Comment 6 Greg Nichols 2007-01-10 12:03:04 EST
did you delete the contents of /var/hts before running R15?

- Thanks,
Greg Nichols.
Comment 7 Garry Wong 2007-01-10 12:12:22 EST
No, this is fresh install for both OS and hts 15. I ran network test first 
then ran virt test.

Thanks,
Comment 8 Greg Nichols 2007-01-12 16:32:11 EST
The test logs (results.xml) indicate that HTS was not successful in writing the
test results file (results.xml) - leaving it incomplete, causing the hts print
and  submit errors.

Could you please do the following:

1) delete /var/hts/results.xml
2) rerun the test via "hts certify --test virt --noinfo", saving the console
output.

Please attach the results - also - what model is the SUT?

Thanks!
Comment 9 Garry Wong 2007-01-16 10:41:43 EST
Created attachment 145695 [details]
virt log

See attached. This is HP ProLiant DL360 G5.

Thanks,
Comment 10 Greg Nichols 2007-01-17 13:10:06 EST
It looks to me that HTS crashed during the virt test.   We will not be using 
the virt test for certification in this release, so I'm Deferring the bug.

Note You need to log in before you can comment on or make changes to this bug.