Bug 220126 - Cannot connect to smb share
Cannot connect to smb share
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
  Show dependency treegraph
Reported: 2006-12-18 19:39 EST by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-11 06:24:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2006-12-18 19:39:20 EST
Description of problem:
This problem seems to be related to, but not quite the same as,




This evening I was trying to connect to an smb share on my local network, from
an FC6 installation created last week.

At first I came across the problem that Nautilus was trying to connect as guest,
but even when I tried using the user@host syntax, the mount still failed,
whereas connecting to the share with smbclient and the same credentials succeeds.

Here are the relevant messages:

kernel: gnome-vfs-daemo[9600]: segfault at 0000000000000020 rip 0000003
331634f24 rsp 00000000409ff940 error 6

process 3833: arguments to dbus_pending_call_unref() were incorrect, assertion
"pending != NU
LL" failed in file dbus-pending-call.c line 563.
This is normally a bug in some application using the D-Bus library.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Use nautilus to connect to an smb share
Actual results:
Error "Unable to connect"

Expected results:
Connect to the share 

Additional info:
Comment 1 Alexander Larsson 2006-12-19 04:34:20 EST
Can you try the gnome-vfs2-2.16.2-2.fc6 update?
Comment 2 Adam Huffman 2006-12-19 14:03:54 EST
Just tried that update and I get the same error.
Comment 3 Adam Huffman 2006-12-19 14:58:54 EST
Actually, upon trying again it does seem to work with that update, thanks.

Note You need to log in before you can comment on or make changes to this bug.