Bug 220129 - yum --changelog error when updating to kernel 2.6.18-1.2798.fc6.i686
yum --changelog error when updating to kernel 2.6.18-1.2798.fc6.i686
Status: CLOSED DUPLICATE of bug 221166
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 20:06 EST by Satish Balay
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 05:15:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2006-12-18 20:06:00 EST
Description of problem:

'yum --changelog update' gives an error with kernel 2.6.18-1.2798.fc6.i686

Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2798.fc6
kernel-2.6.18-1.2849.fc6
yum-3.0.1-2.fc6
yum-changelog-1.0.1-1.fc6


How reproducible:

always

Steps to Reproduce:
1. yum update --changelog
2.
3.
  
Actual results:

[root@asterix ~]# yum update --changelog
Loading "installonlyn" plugin
Loading "changelog" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package faac.i386 0:1.25-2.lvn6 set to be updated
---> Package kernel.i686 0:2.6.18-1.2868.fc6 set to be installed
---> Package kernel-devel.i686 0:2.6.18-1.2868.fc6 set to be installed
---> Package kernel-headers.i386 0:2.6.18-1.2868.fc6 set to be updated
--> Running transaction check

Changes in packages about to be updated:

kernel-devel - 2.6.18-1.2798.fc6.i686, kernel - 2.6.18-1.2868.fc6.i686,
kernel-devel - 2.6.18-1.2868.fc6.i686, kernel-headers - 2.6.18-1.2868.fc6.i386,
kernel - 2.6.18-1.2798.fc6.i686
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/changelog.py", line 99, in postresolve_hook
    show_changes(conduit, 'Changes in packages about to be updated:')
  File "/usr/lib/yum-plugins/changelog.py", line 61, in show_changes
    for line in changelog_delta(srpms[name][0], origpkgs[name]):
  File "/usr/lib/yum-plugins/changelog.py", line 34, in changelog_delta
    if int(date) > olddate:
ValueError: invalid literal for int(): Dave Jones <davej@redhat.com> 
[root@asterix ~]# 


Expected results:

No error


Additional info:

'yum update' works fine [atleast it prints the summary and prompts for the next
step]
Comment 1 Johan Kok 2007-02-05 05:15:35 EST

*** This bug has been marked as a duplicate of 221166 ***

Note You need to log in before you can comment on or make changes to this bug.